summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2021-04-28 09:36:32 +0200
committerGitHub <noreply@github.com>2021-04-28 09:36:32 +0200
commit70387c34b638972b7c51017b81949f32ddd63e39 (patch)
tree7a8f8a59e03b550429377b43f8fca17a6b412499 /src/python/CMakeLists.txt
parent009c01c1d10c681fa441dbd4e4e166bbfd6f70e7 (diff)
parent154596a39b2b26c90e46ec851b8f05ea08fa47d4 (diff)
Merge pull request #483 from VincentRouvreau/make_install_shall_not_install_python_package_bis
Remove make install target from python and rewrite documentation accordingly
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 73303a24..a1440cbc 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -274,8 +274,6 @@ if(PYTHONINTERP_FOUND)
add_custom_target(python ALL DEPENDS gudhi.so
COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
-
set(GUDHI_PYTHON_PATH_ENV "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}:$ENV{PYTHONPATH}")
# Documentation generation is available through sphinx - requires all modules
# Make it first as sphinx test is by far the longest test which is nice when testing in parallel