summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-06-17 15:43:30 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-06-17 15:43:30 +0200
commitcb108929433617f553e0a0c7185b3073cce35696 (patch)
treeead76059c5186a3d09cc160eb881f2ed3b65127a /src/python/CMakeLists.txt
parent486b281c726cbb6110cfe3c63b3f225690bcd348 (diff)
Fix #461 and review all error cases (no more prints, warnings and exceptions instead)
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 98f2b85f..1f0d74d4 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -542,6 +542,10 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_dtm_rips_complex)
endif()
+ # persistence graphical tools
+ if(MATPLOTLIB_FOUND)
+ add_gudhi_py_test(test_persistence_graphical_tools)
+ endif()
# Set missing or not modules
set(GUDHI_MODULES ${GUDHI_MODULES} "python" CACHE INTERNAL "GUDHI_MODULES")