summaryrefslogtreecommitdiff
path: root/src/python/setup.py.in
diff options
context:
space:
mode:
authormathieu <mathieu.carriere3@gmail.com>2020-02-13 19:39:29 -0500
committermathieu <mathieu.carriere3@gmail.com>2020-02-13 19:39:29 -0500
commit5b7df6d0f6807b87ad936f7c322355de22bd516f (patch)
treeae8ee5e642c55a1177046c9f6d1c681f5f38b29c /src/python/setup.py.in
parent266314e4f0a4c767eb2d1bcd321788dddc03320c (diff)
parentbed30b19e57669c0b8ad385f1124586ed3499a2d (diff)
Merge branch 'master' of https://github.com/GUDHI/gudhi-devel into extended_persistence
Diffstat (limited to 'src/python/setup.py.in')
-rw-r--r--src/python/setup.py.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index f993165c..f968bd59 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -8,10 +8,11 @@
- YYYY/MM Author: Description of the modification
"""
-from setuptools import setup, Extension
+from setuptools import setup, Extension, find_packages
from Cython.Build import cythonize
from numpy import get_include as numpy_get_include
import sys
+import pybind11
__author__ = "Vincent Rouvreau"
__copyright__ = "Copyright (C) 2016 Inria"
@@ -42,14 +43,26 @@ for module in modules:
runtime_library_dirs=runtime_library_dirs,
cython_directives = {'language_level': str(sys.version_info[0])},))
+ext_modules = cythonize(ext_modules)
+
+ext_modules.append(Extension(
+ 'gudhi.hera',
+ sources = [source_dir + 'hera.cc'],
+ language = 'c++',
+ include_dirs = include_dirs +
+ ['@HERA_WASSERSTEIN_INCLUDE_DIR@',
+ pybind11.get_include(False), pybind11.get_include(True)],
+ extra_compile_args=extra_compile_args + [@GUDHI_PYBIND11_EXTRA_COMPILE_ARGS@],
+ ))
+
setup(
name = 'gudhi',
- packages=["gudhi","gudhi.representations"],
+ packages=find_packages(), # find_namespace_packages(include=["gudhi*"])
author='GUDHI Editorial Board',
author_email='gudhi-contact@lists.gforge.inria.fr',
version='@GUDHI_VERSION@',
url='http://gudhi.gforge.inria.fr/',
- ext_modules = cythonize(ext_modules),
+ ext_modules = ext_modules,
install_requires = ['cython','numpy >= 1.9',],
- setup_requires = ['numpy >= 1.9',],
+ setup_requires = ['numpy >= 1.9','pybind11',],
)