summaryrefslogtreecommitdiff
path: root/src/python/setup.py.in
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-11-21 10:23:02 +0100
committerGitHub <noreply@github.com>2022-11-21 10:23:02 +0100
commitf361ecc561ea9a3cc8a4d8408bb8e094f211247e (patch)
treecef47c775ebd77f51c3085e5cf7abf517c8e7070 /src/python/setup.py.in
parent58ae82b2fdf5c38ad26d17302dec1e4d3f03fd50 (diff)
parent04370bae13251d0bcce205f253fb758f91fdf207 (diff)
Merge pull request #735 from mglisse/hera2
Update to Hera 2
Diffstat (limited to 'src/python/setup.py.in')
-rw-r--r--src/python/setup.py.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 2c67c2c5..1ecbe985 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -48,10 +48,8 @@ ext_modules = cythonize(ext_modules, compiler_directives={'language_level': '3'}
for module in pybind11_modules:
my_include_dirs = include_dirs + [pybind11.get_include(False), pybind11.get_include(True)]
- if module == 'hera/wasserstein':
- my_include_dirs = ['@HERA_WASSERSTEIN_INCLUDE_DIR@'] + my_include_dirs
- elif module == 'hera/bottleneck':
- my_include_dirs = ['@HERA_BOTTLENECK_INCLUDE_DIR@'] + my_include_dirs
+ if module.startswith('hera/'):
+ my_include_dirs = ['@HERA_INCLUDE_DIR@'] + my_include_dirs
ext_modules.append(Extension(
'gudhi.' + module.replace('/', '.'),
sources = [source_dir + module + '.cc'],