summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-07-05 15:03:57 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-07-05 15:03:57 +0000
commit093866604f986dded2db6a96d7dbc4b6d1f7194a (patch)
tree179a129ccac651c20750993c33d01d4c2c36e586 /src
parent7c205b2cb36b9d8b04556cc81afb4940f27743fc (diff)
Fix default filtration value given by the graph_expansion method with blocker
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/graph_expansion_with_blocker_oracle@2585 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 38586e3c9a622c74c6b6658bdc0a6776c5ea5d5a
Diffstat (limited to 'src')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt17
-rw-r--r--src/Simplex_tree/example/block.cpp30
-rw-r--r--src/Simplex_tree/example/cech_complex_step_by_step.cpp230
-rw-r--r--src/Simplex_tree/include/gudhi/Simplex_tree.h93
4 files changed, 61 insertions, 309 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index 7a30979f..4557deb3 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -34,25 +34,8 @@ if(GMP_FOUND AND CGAL_FOUND)
"${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-
- #
- # TO BE REMOVED !!
- #
-
- add_executable ( Simplex_tree_example_cech_complex_step_by_step cech_complex_step_by_step.cpp )
- target_link_libraries(Simplex_tree_example_cech_complex_step_by_step ${GMP_LIBRARIES} ${CGAL_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_cech_complex_step_by_step ${TBB_LIBRARIES})
- endif()
- add_test(NAME Simplex_tree_example_cech_complex_step_by_step COMMAND $<TARGET_FILE:Simplex_tree_example_cech_complex_step_by_step>
- "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" "-d" "3" "-r" "6.0")
-
endif()
-#
-# TO BE REMOVED !!
-#
-
add_executable ( Simplex_tree_example_block block.cpp )
if (TBB_FOUND)
target_link_libraries(Simplex_tree_example_block ${TBB_LIBRARIES})
diff --git a/src/Simplex_tree/example/block.cpp b/src/Simplex_tree/example/block.cpp
index 75b8d1ea..67697b89 100644
--- a/src/Simplex_tree/example/block.cpp
+++ b/src/Simplex_tree/example/block.cpp
@@ -24,15 +24,13 @@
#include <gudhi/Simplex_tree.h>
#include <iostream>
-#include <utility> // for pair
-#include <vector>
using Simplex_tree = Gudhi::Simplex_tree<>;
using Simplex_handle = Simplex_tree::Simplex_handle;
int main(int argc, char * const argv[]) {
- // Construct the Simplex Tree
+ // Construct the Simplex Tree with a 1-skeleton graph example
Simplex_tree simplexTree;
simplexTree.insert_simplex({0, 1}, 0.);
@@ -46,31 +44,27 @@ int main(int argc, char * const argv[]) {
simplexTree.insert_simplex({4, 5}, 8.);
simplexTree.insert_simplex({4, 6}, 9.);
simplexTree.insert_simplex({5, 6}, 10.);
- simplexTree.insert_simplex({6}, 11.);
-
- std::cout << "********************************************************************\n";
- std::cout << "* The complex contains " << simplexTree.num_simplices() << " simplices\n";
- std::cout << " - dimension " << simplexTree.dimension() << " - filtration " << simplexTree.filtration() << "\n";
- std::cout << "* Iterator on Simplices in the filtration, with [filtration value]:\n";
- for (auto f_simplex : simplexTree.filtration_simplex_range()) {
- std::cout << " " << "[" << simplexTree.filtration(f_simplex) << "] ";
- for (auto vertex : simplexTree.simplex_vertex_range(f_simplex))
- std::cout << "(" << vertex << ")";
- std::cout << std::endl;
- }
+ simplexTree.insert_simplex({6}, 10.);
simplexTree.expansion_with_blockers(3, [&](Simplex_handle sh){
bool result = false;
+ std::cout << "Blocker on [";
+ // User can loop on the vertices from the given simplex_handle i.e.
for (auto vertex : simplexTree.simplex_vertex_range(sh)) {
+ // We block the expansion, if the vertex '6' is in the given list of vertices
if (vertex == 6)
result = true;
- std::cout << "#(" << vertex << ")#";
+ std::cout << vertex << ", ";
}
- std::cout << std::endl;
+ std::cout << "] ( " << simplexTree.filtration(sh);
+ // User can re-assign a new filtration value directly in the blocker (default is the maximal value of boudaries)
+ simplexTree.assign_filtration(sh, simplexTree.filtration(sh) + 1.);
+
+ std::cout << " + 1. ) = " << result << std::endl;
+
return result;
});
- simplexTree.initialize_filtration();
std::cout << "********************************************************************\n";
std::cout << "* The complex contains " << simplexTree.num_simplices() << " simplices\n";
std::cout << " - dimension " << simplexTree.dimension() << " - filtration " << simplexTree.filtration() << "\n";
diff --git a/src/Simplex_tree/example/cech_complex_step_by_step.cpp b/src/Simplex_tree/example/cech_complex_step_by_step.cpp
deleted file mode 100644
index 1805c792..00000000
--- a/src/Simplex_tree/example/cech_complex_step_by_step.cpp
+++ /dev/null
@@ -1,230 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Clément Maria
- *
- * Copyright (C) 2014 INRIA Sophia Antipolis-Méditerranée (France)
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/graph_simplicial_complex.h>
-#include <gudhi/distance_functions.h>
-#include <gudhi/Simplex_tree.h>
-#include <gudhi/Points_off_io.h>
-
-// #include <CGAL/Epick_d.h>
-// #include <CGAL/Euclidean_distance.h>
-// #include <CGAL/Search_traits_d.h>
-#include <CGAL/Epick_d.h>
-#include <CGAL/Min_sphere_of_spheres_d.h>
-#include <CGAL/Min_sphere_of_points_d_traits_d.h>
-
-#include <boost/program_options.hpp>
-
-#include <string>
-#include <vector>
-#include <limits> // infinity
-#include <utility> // for pair
-#include <map>
-
-// ----------------------------------------------------------------------------
-// rips_persistence_step_by_step is an example of each step that is required to
-// build a Rips over a Simplex_tree. Please refer to rips_persistence to see
-// how to do the same thing with the Rips_complex wrapper for less detailed
-// steps.
-// ----------------------------------------------------------------------------
-
-// Types definition
-using Simplex_tree = Gudhi::Simplex_tree<Gudhi::Simplex_tree_options_fast_persistence>;
-using Vertex_handle = Simplex_tree::Vertex_handle;
-using Simplex_handle = Simplex_tree::Simplex_handle;
-using Filtration_value = Simplex_tree::Filtration_value;
-using Siblings = Simplex_tree::Siblings;
-using Graph_t = boost::adjacency_list < boost::vecS, boost::vecS, boost::undirectedS
-, boost::property < vertex_filtration_t, Filtration_value >
-, boost::property < edge_filtration_t, Filtration_value >
->;
-using Edge_t = std::pair< Vertex_handle, Vertex_handle >;
-
-using Kernel = CGAL::Epick_d< CGAL::Dimension_tag<2> >;// CGAL::Dynamic_dimension_tag >;
-using Point = Kernel::Point_d;
-using Traits = CGAL::Min_sphere_of_points_d_traits_d<Kernel,Filtration_value,2>;
-using Min_sphere = CGAL::Min_sphere_of_spheres_d<Traits>;
-
-using Points_off_reader = Gudhi::Points_off_reader<Point>;
-
-class Cech_blocker {
- public:
- bool operator()(Simplex_handle sh) {
- std::vector<Point> points;
- for (auto vertex : simplex_tree_.simplex_vertex_range(sh)) {
- points.push_back(point_cloud_[vertex]);
- std::cout << "#(" << vertex << ")#";
- }
- Min_sphere ms(points.begin(),points.end());
- Filtration_value radius = ms.radius();
- std::cout << "radius = " << radius << " - " << (radius > threshold_) << std::endl;
- simplex_tree_.assign_filtration(sh, radius);
- return (radius > threshold_);
- }
- Cech_blocker(Simplex_tree& simplex_tree, Filtration_value threshold, const std::vector<Point>& point_cloud)
- : simplex_tree_(simplex_tree),
- threshold_(threshold),
- point_cloud_(point_cloud) { }
- private:
- Simplex_tree simplex_tree_;
- Filtration_value threshold_;
- std::vector<Point> point_cloud_;
-};
-
-template< typename InputPointRange>
-Graph_t compute_proximity_graph(InputPointRange &points, Filtration_value threshold);
-
-void program_options(int argc, char * argv[]
- , std::string & off_file_points
- , Filtration_value & threshold
- , int & dim_max);
-
-int main(int argc, char * argv[]) {
- std::string off_file_points;
- Filtration_value threshold;
- int dim_max;
-
- program_options(argc, argv, off_file_points, threshold, dim_max);
-
- // Extract the points from the file filepoints
- Points_off_reader off_reader(off_file_points);
-
- // Compute the proximity graph of the points
- Graph_t prox_graph = compute_proximity_graph(off_reader.get_point_cloud(), threshold);
-
- //Min_sphere sph1(off_reader.get_point_cloud()[0], off_reader.get_point_cloud()[1], off_reader.get_point_cloud()[2]);
- // Construct the Rips complex in a Simplex Tree
- Simplex_tree st;
- // insert the proximity graph in the simplex tree
- st.insert_graph(prox_graph);
- // expand the graph until dimension dim_max
- st.expansion_with_blockers(dim_max, Cech_blocker(st, threshold, off_reader.get_point_cloud()));
-
- std::cout << "The complex contains " << st.num_simplices() << " simplices \n";
- std::cout << " and has dimension " << st.dimension() << " \n";
-
- // Sort the simplices in the order of the filtration
- st.initialize_filtration();
-
- std::cout << "********************************************************************\n";
- // Display the Simplex_tree - Can not be done in the middle of 2 inserts
- std::cout << "* The complex contains " << st.num_simplices() << " simplices\n";
- std::cout << " - dimension " << st.dimension() << " - filtration " << st.filtration() << "\n";
- std::cout << "* Iterator on Simplices in the filtration, with [filtration value]:\n";
- for (auto f_simplex : st.filtration_simplex_range()) {
- std::cout << " " << "[" << st.filtration(f_simplex) << "] ";
- for (auto vertex : st.simplex_vertex_range(f_simplex)) {
- std::cout << static_cast<int>(vertex) << " ";
- }
- std::cout << std::endl;
- }
-
- return 0;
-}
-
-void program_options(int argc, char * argv[]
- , std::string & off_file_points
- , Filtration_value & threshold
- , int & dim_max) {
- namespace po = boost::program_options;
- po::options_description hidden("Hidden options");
- hidden.add_options()
- ("input-file", po::value<std::string>(&off_file_points),
- "Name of an OFF file containing a point set.\n");
-
- po::options_description visible("Allowed options", 100);
- visible.add_options()
- ("help,h", "produce help message")
- ("max-edge-length,r",
- po::value<Filtration_value>(&threshold)->default_value(std::numeric_limits<Filtration_value>::infinity()),
- "Maximal length of an edge for the Rips complex construction.")
- ("cpx-dimension,d", po::value<int>(&dim_max)->default_value(1),
- "Maximal dimension of the Rips complex we want to compute.");
-
- po::positional_options_description pos;
- pos.add("input-file", 1);
-
- po::options_description all;
- all.add(visible).add(hidden);
-
- po::variables_map vm;
- po::store(po::command_line_parser(argc, argv).
- options(all).positional(pos).run(), vm);
- po::notify(vm);
-
- if (vm.count("help") || !vm.count("input-file")) {
- std::cout << std::endl;
- std::cout << "Construct a Cech complex defined on a set of input points.\n \n";
-
- std::cout << "Usage: " << argv[0] << " [options] input-file" << std::endl << std::endl;
- std::cout << visible << std::endl;
- std::abort();
- }
-}
-
-/** Output the proximity graph of the points.
- *
- * If points contains n elements, the proximity graph is the graph
- * with n vertices, and an edge [u,v] iff the distance function between
- * points u and v is smaller than threshold.
- *
- * The type PointCloud furnishes .begin() and .end() methods, that return
- * iterators with value_type Point.
- */
-template< typename InputPointRange>
-Graph_t compute_proximity_graph(InputPointRange &points, Filtration_value threshold) {
- std::vector< Edge_t > edges;
- std::vector< Filtration_value > edges_fil;
-
- Kernel k;
- Vertex_handle idx_u, idx_v;
- Filtration_value fil;
- idx_u = 0;
- for (auto it_u = points.begin(); it_u != points.end(); ++it_u) {
- idx_v = idx_u + 1;
- for (auto it_v = it_u + 1; it_v != points.end(); ++it_v, ++idx_v) {
- fil = k.squared_distance_d_object()(*it_u, *it_v);
- // For Cech Complex, threshold is a radius (distance /2)
- fil = std::sqrt(fil) / 2.;
- if (fil <= threshold) {
- edges.emplace_back(idx_u, idx_v);
- edges_fil.push_back(fil);
- }
- }
- ++idx_u;
- }
-
- Graph_t skel_graph(edges.begin()
- , edges.end()
- , edges_fil.begin()
- , idx_u); // number of points labeled from 0 to idx_u-1
-
- auto vertex_prop = boost::get(vertex_filtration_t(), skel_graph);
-
- boost::graph_traits<Graph_t>::vertex_iterator vi, vi_end;
- for (std::tie(vi, vi_end) = boost::vertices(skel_graph);
- vi != vi_end; ++vi) {
- boost::put(vertex_prop, *vi, 0.);
- }
-
- return skel_graph;
-}
diff --git a/src/Simplex_tree/include/gudhi/Simplex_tree.h b/src/Simplex_tree/include/gudhi/Simplex_tree.h
index ff31fd89..72cb9401 100644
--- a/src/Simplex_tree/include/gudhi/Simplex_tree.h
+++ b/src/Simplex_tree/include/gudhi/Simplex_tree.h
@@ -1081,31 +1081,23 @@ class Simplex_tree {
}
}
-
-
- /*-------------------------------------------------------------------------------------------------------------------------*/
- /*-------------------------------------------------------------------------------------------------------------------------*/
- /*-------------------------------------------------------------------------------------------------------------------------*/
-
public:
- /** \brief Expands the Simplex_tree containing only its one skeleton
- * until dimension max_dim.
+ /** \brief Expands the Simplex_tree containing only its one skeleton until dimension max_dim according with a user
+ * given blocker expansion oracle
*
- * The expanded simplicial complex until dimension \f$d\f$
- * attached to a graph \f$G\f$ is the maximal simplicial complex of
- * dimension at most \f$d\f$ admitting the graph \f$G\f$ as \f$1\f$-skeleton.
- * The filtration value assigned to a simplex is the maximal filtration
- * value of one of its edges.
+ * The expanded simplicial complex until dimension \f$d\f$ attached to a graph \f$G\f$ is the maximal simplicial
+ * complex of dimension at most \f$d\f$ admitting the graph \f$G\f$ as \f$1\f$-skeleton.
+ * The filtration value assigned to a simplex is the maximal filtration value of one of its edges.
+ * The blocker expansion oracle shall answer true on a Simplex_handle if this Simplex_handle has to be removed,
+ * false otherwise. The blocker expansion oracle can re-assign the filtration value.
*
- * The Simplex_tree must contain no simplex of dimension bigger than
- * 1 when calling the method. */
+ * The Simplex_tree must contain no simplex of dimension bigger than 1 when calling the method. */
template< typename Blocker >
void expansion_with_blockers(int max_dim, Blocker blocker_expansion_function) {
dimension_ = max_dim;
// Loop must be from the end to the beginning, as higher dimension simplex are always on the left part of the tree
for (auto& simplex : boost::adaptors::reverse(root_.members())) {
if (has_children(&simplex)) {
- std::cout << " *** root on " << static_cast<int>(simplex.first) << std::endl;
siblings_expansion_with_blockers(simplex.second.children(), max_dim - 1, blocker_expansion_function);
}
}
@@ -1113,7 +1105,7 @@ class Simplex_tree {
}
private:
- /** \brief Recursive expansion of the simplex tree.*/
+ /** \brief Recursive expansion with blockers of the simplex tree.*/
template< typename Blocker >
void siblings_expansion_with_blockers(Siblings* siblings, // must contain elements
int k, Blocker blocker_expansion_function) {
@@ -1131,22 +1123,16 @@ class Simplex_tree {
std::vector<std::pair<Vertex_handle, Node> > intersection;
while(next != simplex) {
bool to_be_inserted = true;
- std::cout << "to_be_inserted = " << to_be_inserted << " dim = " << k << " simplex = " << simplex->first << " - next = " << next->first << std::endl;
-
+ Filtration_value filt = simplex->second.filtration();
+ // If all the boundaries are present, 'next' needs to be inserted
for (auto& border : boundary_simplex_range(simplex)) {
- to_be_inserted = to_be_inserted && find_child(border, next->first);
-
- for (auto vertex : simplex_vertex_range(border)) {
- std::cout << "(" << vertex << ")";
- }
- std::cout << " | ";
+ Simplex_handle border_child = find_child(border, next->first);
+ to_be_inserted = to_be_inserted && (border_child != null_simplex());
+ filt = std::max(filt, filtration(border_child));
}
- std::cout << std::endl;
if (to_be_inserted) {
- std::cout << next->first << " to be inserted." << std::endl;
- intersection.emplace_back(next->first, Node(nullptr, 0.0));
+ intersection.emplace_back(next->first, Node(nullptr, filt));
}
-
// loop until simplex is reached
next++;
}
@@ -1158,34 +1144,50 @@ class Simplex_tree {
intersection); // boost::container::ordered_unique_range_t
// intersection must be cleared before the function to be called recursively
intersection.clear();
- simplex->second.assign_children(new_sib);
- siblings_expansion_with_blockers(new_sib, k - 1, blocker_expansion_function);
+
+ std::vector<Simplex_handle> blocked_new_sib_list;
+ // As all intersections are inserted, we can call the blocker function on all new_sib members
+ for (auto new_sib_member = new_sib->members().begin();
+ new_sib_member != new_sib->members().end();
+ new_sib_member++) {
+ bool blocker_result = blocker_expansion_function(new_sib_member);
+ // new_sib member has been blocked by the blocker function
+ // add it to the list to be removed - do not perform it while looping on it
+ if (blocker_result)
+ blocked_new_sib_list.push_back(new_sib_member);
+ }
+ bool removed = false;
+ for (auto& blocked_new_sib_member : blocked_new_sib_list){
+ removed = removed || remove_maximal_simplex(blocked_new_sib_member);
+ }
+ if (removed) {
+ // ensure the children property
+ simplex->second.assign_children(siblings);
+ } else {
+ // ensure recursive call
+ simplex->second.assign_children(new_sib);
+ siblings_expansion_with_blockers(new_sib, k - 1, blocker_expansion_function);
+ }
} else {
// ensure the children property
simplex->second.assign_children(siblings);
intersection.clear();
}
-
}
-
}
- /** \private Returns true if vh is a member of sh*/
- bool find_child(Simplex_handle sh, Vertex_handle vh) {
+ /* \private Returns the Simplex_handle composed of the vertex list (from the Simplex_handle), plus the given
+ * Vertex_handle.
+ * Returns null_simplex() if it does not exist
+ */
+ Simplex_handle find_child(Simplex_handle sh, Vertex_handle vh) {
std::vector<Vertex_handle> child = {vh};
- std::cout << "+" << vh;
for (auto vertex : simplex_vertex_range(sh)) {
- std::cout << "+" << vertex;
child.push_back(vertex);
}
- std::cout << " => " << (find(child) != null_simplex()) << "___ ";
- return find(child) != null_simplex();
+ return find(child);
}
- /*-------------------------------------------------------------------------------------------------------------------------*/
- /*-------------------------------------------------------------------------------------------------------------------------*/
- /*-------------------------------------------------------------------------------------------------------------------------*/
-
public:
/** \brief Write the hasse diagram of the simplicial complex in os.
*
@@ -1295,11 +1297,12 @@ class Simplex_tree {
public:
/** \brief Remove a maximal simplex.
* @param[in] sh Simplex handle on the maximal simplex to remove.
+ * @return true if siblings was deleted, false otherwise.
* \pre Please check the simplex has no coface before removing it.
* \exception std::invalid_argument In debug mode, if sh has children.
* \post Be aware that removing is shifting data in a flat_map (initialize_filtration to be done).
*/
- void remove_maximal_simplex(Simplex_handle sh) {
+ bool remove_maximal_simplex(Simplex_handle sh) {
// Guarantee the simplex has no children
GUDHI_CHECK(!has_children(sh),
std::invalid_argument("Simplex_tree::remove_maximal_simplex - argument has children"));
@@ -1315,7 +1318,9 @@ class Simplex_tree {
// Sibling is emptied : must be deleted, and its parent must point on his own Sibling
child->oncles()->members().at(child->parent()).assign_children(child->oncles());
delete child;
+ return true;
}
+ return false;
}
private: