summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-10-25 11:43:09 +0200
committerHind-M <hind.montassif@gmail.com>2021-10-25 11:43:09 +0200
commitc9d6439fb9a6e65d7aa9f18bce675de65e901a0d (patch)
treef2183dbf77a3554471ec84ad42c0cc36db41b8d4 /src
parentc2bdc8a749449d41ec367089aecd975fe633c121 (diff)
Rename WITH_NETWORK option to WITH_GUDHI_REMOTE_TEST
Diffstat (limited to 'src')
-rw-r--r--src/cmake/modules/GUDHI_modules.cmake2
-rw-r--r--src/common/doc/installation.h4
-rw-r--r--src/python/CMakeLists.txt2
3 files changed, 4 insertions, 4 deletions
diff --git a/src/cmake/modules/GUDHI_modules.cmake b/src/cmake/modules/GUDHI_modules.cmake
index 9cc1a8f5..7cdce307 100644
--- a/src/cmake/modules/GUDHI_modules.cmake
+++ b/src/cmake/modules/GUDHI_modules.cmake
@@ -19,7 +19,7 @@ endfunction(add_gudhi_module)
option(WITH_GUDHI_BENCHMARK "Activate/deactivate benchmark compilation" OFF)
option(WITH_GUDHI_EXAMPLE "Activate/deactivate examples compilation and installation" OFF)
-option(WITH_NETWORK "Activate/deactivate datasets fetching test which uses the Internet" OFF)
+option(WITH_GUDHI_REMOTE_TEST "Activate/deactivate datasets fetching test which uses the Internet" OFF)
option(WITH_GUDHI_PYTHON "Activate/deactivate python module compilation and installation" ON)
option(WITH_GUDHI_TEST "Activate/deactivate examples compilation and installation" ON)
option(WITH_GUDHI_UTILITIES "Activate/deactivate utilities compilation and installation" ON)
diff --git a/src/common/doc/installation.h b/src/common/doc/installation.h
index 72d4b1e5..b0fbdf20 100644
--- a/src/common/doc/installation.h
+++ b/src/common/doc/installation.h
@@ -40,8 +40,8 @@ make \endverbatim
* `make test` is using <a href="https://cmake.org/cmake/help/latest/manual/ctest.1.html">Ctest</a> (CMake test driver
* program). If some of the tests are failing, please send us the result of the following command:
* \verbatim ctest --output-on-failure \endverbatim
- * Testing fetching datasets feature requires the use of the internet and is disabled by default. If you want to include this test, set WITH_NETWORK to ON when building in the previous step (note that this test is included in the python module):
- * \verbatim cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON --DWITH_GUDHI_PYTHON=ON .. \endverbatim
+ * Testing fetching datasets feature requires the use of the internet and is disabled by default. If you want to include this test, set WITH_GUDHI_REMOTE_TEST to ON when building in the previous step (note that this test is included in the python module):
+ * \verbatim cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_REMOTE_TEST=ON --DWITH_GUDHI_PYTHON=ON .. \endverbatim
*
* \subsection documentationgeneration Documentation
* To generate the documentation, <a target="_blank" href="http://www.doxygen.org/">Doxygen</a> is required.
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 6c8dfe32..ddb5c9c2 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -543,7 +543,7 @@ if(PYTHONINTERP_FOUND)
endif()
# Fetch remote datasets
- if(WITH_NETWORK)
+ if(WITH_GUDHI_REMOTE_TEST)
add_gudhi_py_test(test_remote_datasets)
endif()