summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-02-19 17:31:05 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2021-02-19 17:31:05 +0100
commit3aa03afd487dbaee677f07d433e142d533d89015 (patch)
tree1f758b12c9256b44d2818322fd1f641c62b4e1ef /src
parent6c546aaa74679349dec98beef4f2c95f1d3b6055 (diff)
Revert "Partial fix of #416"
This reverts commit 6c546aaa74679349dec98beef4f2c95f1d3b6055.
Diffstat (limited to 'src')
-rw-r--r--src/python/CMakeLists.txt4
-rw-r--r--src/python/setup.py.in2
2 files changed, 4 insertions, 2 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 27069ff6..5c1402a6 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -247,7 +247,6 @@ if(PYTHONINTERP_FOUND)
endif(UNIX AND WITH_GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS)
# Generate setup.py file to cythonize Gudhi - This file must be named setup.py by convention
- set(GUDHI_SETUP_PY_INTRODUCTION_RST "${CMAKE_CURRENT_SOURCE_DIR}/introduction.rst")
configure_file(setup.py.in "${CMAKE_CURRENT_BINARY_DIR}/setup.py" @ONLY)
# Generate gudhi/__init__.py
@@ -264,6 +263,9 @@ if(PYTHONINTERP_FOUND)
file(COPY "gudhi/dtm_rips_complex.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi")
file(COPY "gudhi/hera/__init__.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi/hera")
+ # Some files for pip package
+ file(COPY "introduction.rst" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
+
add_custom_command(
OUTPUT gudhi.so
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 2c9d40b5..98d058fc 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -65,7 +65,7 @@ for module in pybind11_modules:
))
# read the contents of introduction.rst
-with open("@GUDHI_SETUP_PY_INTRODUCTION_RST@", "r") as fh:
+with open("introduction.rst", "r") as fh:
long_description = fh.read()
setup(