summaryrefslogtreecommitdiff
path: root/utilities/Nerve_GIC/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-02-02 14:05:27 +0100
committerGard Spreemann <gspreemann@gmail.com>2018-02-02 14:05:27 +0100
commitdf9caafd97960a610906a79cf40ba52e40c6cf48 (patch)
treea9c0b0330239e6438510432b0ba78f35799224d9 /utilities/Nerve_GIC/CMakeLists.txt
parent5bb200877fac0090032b9d56b782d2ae361efa9b (diff)
parent8e51c74d8855a641c006765ee246402e218828f3 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'utilities/Nerve_GIC/CMakeLists.txt')
-rw-r--r--utilities/Nerve_GIC/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
new file mode 100644
index 00000000..7762c8a0
--- /dev/null
+++ b/utilities/Nerve_GIC/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 2.6)
+project(Nerve_GIC_examples)
+
+if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ add_executable ( Nerve Nerve.cpp )
+ add_executable ( VoronoiGIC VoronoiGIC.cpp )
+
+ if (TBB_FOUND)
+ target_link_libraries(Nerve ${TBB_LIBRARIES})
+ target_link_libraries(VoronoiGIC ${TBB_LIBRARIES})
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+ "human.off" "2" "10" "0.3")
+
+ add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+ "human.off" "100")
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)