summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-02-02 14:03:28 +0100
committerGard Spreemann <gspreemann@gmail.com>2018-02-02 14:03:28 +0100
commit8e51c74d8855a641c006765ee246402e218828f3 (patch)
treefcd070128c18c0b8cb16c841911c2fba3e209e96 /utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
parent0b7c2ce340ece752c4d1b799a94419ca248eb71f (diff)
parent9899ae167f281d10b1684dfcd02c6838c5bf28df (diff)
Merge branch 'upstream/latest' into dfsg/latest
Diffstat (limited to 'utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt')
-rw-r--r--utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt b/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
new file mode 100644
index 00000000..c5ea4bbf
--- /dev/null
+++ b/utilities/Persistence_representations/persistence_landscapes_on_grid/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.6)
+project(Persistence_representations_lanscapes_on_grid_utilities)
+
+# Need to set grid min and max for further average, distance and scalar_product
+add_persistence_representation_creation_utility(create_landscapes_on_grid "100" "0" "35" "-1")
+
+add_persistence_representation_plot_utility(plot_landscapes_on_grid ".g_land")
+
+add_persistence_representation_function_utility(average_landscapes_on_grid ".g_land")
+add_persistence_representation_function_utility(compute_distance_of_landscapes_on_grid ".g_land" "1")
+add_persistence_representation_function_utility(compute_scalar_product_of_landscapes_on_grid ".g_land")