summaryrefslogtreecommitdiff
path: root/utilities/Witness_complex/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2018-02-02 14:03:28 +0100
committerGard Spreemann <gspreemann@gmail.com>2018-02-02 14:03:28 +0100
commit8e51c74d8855a641c006765ee246402e218828f3 (patch)
treefcd070128c18c0b8cb16c841911c2fba3e209e96 /utilities/Witness_complex/CMakeLists.txt
parent0b7c2ce340ece752c4d1b799a94419ca248eb71f (diff)
parent9899ae167f281d10b1684dfcd02c6838c5bf28df (diff)
Merge branch 'upstream/latest' into dfsg/latest
Diffstat (limited to 'utilities/Witness_complex/CMakeLists.txt')
-rw-r--r--utilities/Witness_complex/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/utilities/Witness_complex/CMakeLists.txt b/utilities/Witness_complex/CMakeLists.txt
new file mode 100644
index 00000000..125a41ff
--- /dev/null
+++ b/utilities/Witness_complex/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 2.6)
+project(Witness_complex_utilities)
+
+# CGAL and Eigen3 are required for Euclidean version of Witness
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
+
+ add_executable ( Witness_complex_strong_witness_persistence strong_witness_persistence.cpp )
+ target_link_libraries(Witness_complex_strong_witness_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY})
+
+ add_executable ( Witness_complex_weak_witness_persistence weak_witness_persistence.cpp )
+ target_link_libraries(Witness_complex_weak_witness_persistence ${Boost_PROGRAM_OPTIONS_LIBRARY})
+
+ if (TBB_FOUND)
+ target_link_libraries(Witness_complex_strong_witness_persistence ${TBB_LIBRARIES})
+ target_link_libraries(Witness_complex_weak_witness_persistence ${TBB_LIBRARIES})
+ endif()
+
+ add_test(NAME Witness_complex_strong_test_torus_persistence
+ COMMAND $<TARGET_FILE:Witness_complex_strong_witness_persistence>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-l" "20" "-a" "0.5")
+ add_test(NAME Witness_complex_weak_test_torus_persistence
+ COMMAND $<TARGET_FILE:Witness_complex_weak_witness_persistence>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-l" "20" "-a" "0.5")
+
+ install(TARGETS Witness_complex_strong_witness_persistence DESTINATION bin)
+ install(TARGETS Witness_complex_weak_witness_persistence DESTINATION bin)
+
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)