summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml5
1 files changed, 4 insertions, 1 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 9ff8f157..b44e08e1 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -29,6 +29,9 @@ environment:
- target: Python
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
+ - target: PythonTestsWithNetwork
+ CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_NETWORK=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
+
cache:
- c:\Tools\vcpkg\installed
@@ -56,7 +59,7 @@ build_script:
- mkdir build
- cd build
- cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% %CMAKE_GMP_FLAGS% %CMAKE_MPFR_FLAGS% %CMAKE_VCPKG_FLAGS% ..
- - if [%target%]==[Python] (
+ - if [[%target%]==[Python] || [%target%]==[PythonTestsWithNetwork]] (
cd src/python &
type setup.py &
MSBuild Cython.sln /m /p:Configuration=Release /p:Platform=x64 &