summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt1
-rw-r--r--src/Bottleneck_distance/utils/CMakeLists.txt16
2 files changed, 0 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7ebb9c6..1346f5d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -161,7 +161,6 @@ else()
add_subdirectory(src/Bottleneck_distance/example)
add_subdirectory(src/Bottleneck_distance/test)
add_subdirectory(src/Bottleneck_distance/benchmark)
- add_subdirectory(src/Bottleneck_distance/utils)
add_subdirectory(src/Rips_complex/example)
add_subdirectory(src/Rips_complex/test)
diff --git a/src/Bottleneck_distance/utils/CMakeLists.txt b/src/Bottleneck_distance/utils/CMakeLists.txt
deleted file mode 100644
index febadea1..00000000
--- a/src/Bottleneck_distance/utils/CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-project(Bottleneck_distance_utils)
-
-# requires CGAL 4.8
-# cmake -DCGAL_DIR=~/workspace/CGAL-4.8 ../../..
-if(CGAL_FOUND)
- if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
- if (EIGEN3_FOUND)
- add_executable (alpha_rips_persistence_bottleneck_distance alpha_rips_persistence_bottleneck_distance.cpp)
- target_link_libraries(alpha_rips_persistence_bottleneck_distance ${Boost_SYSTEM_LIBRARY} ${Boost_PROGRAM_OPTIONS_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(alpha_rips_persistence_bottleneck_distance ${TBB_LIBRARIES})
- endif(TBB_FOUND)
- endif(EIGEN3_FOUND)
- endif(NOT CGAL_VERSION VERSION_LESS 4.8.0)
-endif(CGAL_FOUND)