summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/Kernels/example/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Kernels/example/CMakeLists.txt b/src/Kernels/example/CMakeLists.txt
new file mode 100644
index 00000000..d8ad4b42
--- /dev/null
+++ b/src/Kernels/example/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 2.6)
+project(Kernels_examples)
+
+add_executable ( BasicEx kernel_basic_example.cpp )
+
+if (TBB_FOUND)
+ target_link_libraries(BasicEx ${TBB_LIBRARIES})
+endif()
+
+add_test(NAME Kernels_example_basicex COMMAND $<TARGET_FILE:BasicEx> "${CMAKE_SOURCE_DIR}/data/persistence_diagram/PD1" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/PD2") \ No newline at end of file