summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--src/CMakeLists.txt6
-rw-r--r--src/Simplex_tree/include/gudhi/Simplex_tree.h5
3 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 450b8f69..ea99565a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ find_package(GMP)
if(GMP_FOUND)
find_package(GMPXX)
endif()
-find_package(CGAL)
+find_package(CGAL 4.4)
# Required programs for unitary tests purpose
FIND_PROGRAM( LCOV_PATH lcov )
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dcdf6e87..b15cfe98 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -18,6 +18,12 @@ endif()
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
find_package(Boost)
+find_package(GMP)
+if(GMP_FOUND)
+ find_package(GMPXX)
+endif()
+find_package(CGAL 4.4)
+
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
else()
diff --git a/src/Simplex_tree/include/gudhi/Simplex_tree.h b/src/Simplex_tree/include/gudhi/Simplex_tree.h
index 95f26510..c866d179 100644
--- a/src/Simplex_tree/include/gudhi/Simplex_tree.h
+++ b/src/Simplex_tree/include/gudhi/Simplex_tree.h
@@ -38,7 +38,7 @@
namespace Gudhi {
-
+/** \defgroup simplex_tree Filtered Complexes
/** \defgroup simplex_tree Filtered Complexes
*
* A simplicial complex \f$\mathbf{K}\f$
@@ -117,8 +117,7 @@ class Simplex_tree {
friend class Simplex_tree_complex_simplex_iterator< Simplex_tree<FiltrationValue, SimplexKey, VertexHandle> >;
friend class Simplex_tree_skeleton_simplex_iterator< Simplex_tree<FiltrationValue, SimplexKey, VertexHandle> >;
-
-
+ /* \brief Set of nodes sharing a same parent in the simplex tree. */
/* \brief Set of nodes sharing a same parent in the simplex tree. */
typedef Simplex_tree_siblings<Simplex_tree, Dictionary> Siblings;