summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/pip-packaging-windows.yml32
1 files changed, 19 insertions, 13 deletions
diff --git a/.github/workflows/pip-packaging-windows.yml b/.github/workflows/pip-packaging-windows.yml
index 1cadf6b1..eec7b1a9 100644
--- a/.github/workflows/pip-packaging-windows.yml
+++ b/.github/workflows/pip-packaging-windows.yml
@@ -1,8 +1,15 @@
name: pip packaging windows
-on:
- release:
- types: [published]
+#on:
+# release:
+# types: [published]
+
+on:
+ push:
+ branches:
+ - '*'
+ - '*/*'
+ - '**'
jobs:
build:
@@ -22,21 +29,20 @@ jobs:
architecture: x64
- name: Install dependencies
run: |
- vcpkg install boost-graph:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
+ vcpkg install boost-graph boost-serialization boost-date-time boost-system boost-filesystem boost-units boost-thread boost-program-options eigen3 mpfr mpir cgal --triplet x64-windows
+ vcpkg list
python -m pip install --user -r .github/build-requirements.txt
python -m pip install --user twine
- - name: Build python wheel
- run: |
- python --version
+ python -m pip list
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DGMP_INCLUDE_DIR="c:/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/vcpkg/installed/x64-windows/lib" -DCMAKE_TOOLCHAIN_FILE=C:/vcpkg/scripts/buildsystems/vcpkg.cmake -DPython_ADDITIONAL_VERSIONS=3 ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DGMP_INCLUDE_DIR="c:/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/vcpkg/installed/x64-windows/lib" -DCMAKE_TOOLCHAIN_FILE=C:/vcpkg/scripts/buildsystems/vcpkg.cmake -DVCPKG_TARGET_TRIPLET=x64-windows -DPython_ADDITIONAL_VERSIONS=3 ..
cd src/python
cp c:/vcpkg/installed/x64-windows/bin/mpfr.dll gudhi/
cp c:/vcpkg/installed/x64-windows/bin/mpir.dll gudhi/
python setup.py bdist_wheel
- - name: Publish on PyPi
- env:
- TWINE_USERNAME: __token__
- TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
- run: python -m twine upload build/src/python/dist/*
+# - name: Publish on PyPi
+# env:
+# TWINE_USERNAME: __token__
+# TWINE_PASSWORD: ${{ secrets.PYPI_PASSWORD }}
+# run: python -m twine upload build/src/python/dist/*