summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt4
-rw-r--r--src/CMakeLists.txt4
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt1
-rw-r--r--src/common/doc/main_page.h2
4 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e8f2460..bffba902 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,12 +22,12 @@ endif()
# BOOST ISSUE result_of vs C++11
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
find_package(Boost)
-find_package(GMP 4.2)
+find_package(GMP)
if(GMP_FOUND)
find_package(GMPXX)
endif()
-find_package(CGAL 4.4)
+find_package(CGAL)
# Required programs for unitary tests purpose
FIND_PROGRAM( LCOV_PATH lcov )
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 514a4962..63a70496 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -19,11 +19,11 @@ endif()
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
find_package(Boost)
-find_package(GMP 4.2)
+find_package(GMP)
if(GMP_FOUND)
find_package(GMPXX)
endif()
-find_package(CGAL 4.4)
+find_package(CGAL)
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index 08ebc294..4d05c77a 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -3,7 +3,6 @@ project(GUDHIExPersCohom)
add_executable(rips_persistence rips_persistence.cpp)
-
target_link_libraries(rips_persistence ${Boost_LIBRARY_DIR})
add_test(rips_persistence_2 ${CMAKE_CURRENT_BINARY_DIR}/rips_persistence ${CMAKE_SOURCE_DIR}/data/points/Kl.txt -r 0.25 -d 3 -p 2 -m 100)
diff --git a/src/common/doc/main_page.h b/src/common/doc/main_page.h
index b2c8bca5..83908905 100644
--- a/src/common/doc/main_page.h
+++ b/src/common/doc/main_page.h
@@ -40,7 +40,7 @@ CGAL is a C++ library which provides easy access to efficient and reliable geome
The following example requires CGAL https://www.cgal.org/ and will not be built if CGAL is not installed:
- Simplex_tree/simplex_tree_from_alpha_shapes_3
-Having CGAL version 4.5 or higher installed is recommended. The procedure to install this library according to
+Having CGAL version 4.4 or higher installed is recommended. The procedure to install this library according to
your operating system is detailed here http://doc.cgal.org/latest/Manual/installation.html
\section demos Demos and Examples