summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 2c568b66..9af85eac 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -388,9 +388,9 @@ if(PYTHONINTERP_FOUND)
endif(OT_FOUND)
# Representations
- if(SKLEARN_FOUND)
+ if(SKLEARN_FOUND AND MATPLOTLIB_FOUND)
add_gudhi_py_test(test_representations)
- endif(SKLEARN_FOUND)
+ endif()
# Documentation generation is available through sphinx - requires all modules
if(SPHINX_PATH)