summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt17
-rw-r--r--src/Alpha_shapes/test/CMakeLists.txt1
-rw-r--r--src/Bottleneck/test/CMakeLists.txt1
-rw-r--r--src/Persistent_cohomology/test/CMakeLists.txt1
-rw-r--r--src/Simplex_tree/test/CMakeLists.txt1
-rw-r--r--src/Skeleton_blocker/test/CMakeLists.txt1
6 files changed, 0 insertions, 22 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b70ca6a..f30c1785 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,23 +42,6 @@ if (GPROF_PATH)
message("gprof found in ${GPROF_PATH}")
endif()
-FIND_PROGRAM( PYTHON_PATH python )
-if (PYTHON_PATH)
- message("python found in ${PYTHON_PATH}")
-endif()
-
-# Function to add_test cpplint on each header file of the Gudhi module
-function(cpplint_add_tests the_directory)
- if (PYTHON_PATH)
- # Cpplint tests on coding style
- file(GLOB files "${the_directory}/*.h" "${the_directory}/*/*.h")
- foreach(filename ${files})
- message(${filename})
- add_test("${filename}.cpplint" ${CMAKE_SOURCE_DIR}/scripts/check_google_style.sh ${filename} ${CMAKE_SOURCE_DIR}/scripts/cpplint.py)
- endforeach()
- endif()
-endfunction(cpplint_add_tests)
-
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
diff --git a/src/Alpha_shapes/test/CMakeLists.txt b/src/Alpha_shapes/test/CMakeLists.txt
index 821aa5f2..7d61a3dd 100644
--- a/src/Alpha_shapes/test/CMakeLists.txt
+++ b/src/Alpha_shapes/test/CMakeLists.txt
@@ -45,4 +45,3 @@ if(CGAL_FOUND)
endif ()
endif()
-cpplint_add_tests("${CMAKE_SOURCE_DIR}/src/Alpha_shapes/include/gudhi")
diff --git a/src/Bottleneck/test/CMakeLists.txt b/src/Bottleneck/test/CMakeLists.txt
index 44be61f2..3dfd80cd 100644
--- a/src/Bottleneck/test/CMakeLists.txt
+++ b/src/Bottleneck/test/CMakeLists.txt
@@ -23,4 +23,3 @@ add_test(NAME BottleneckUT
# XML format for Jenkins xUnit plugin
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/BottleneckUT.xml --log_level=test_suite --report_level=no)
-cpplint_add_tests("${CMAKE_SOURCE_DIR}/src/Bottleneck/include/gudhi")
diff --git a/src/Persistent_cohomology/test/CMakeLists.txt b/src/Persistent_cohomology/test/CMakeLists.txt
index 3258fe19..ed63a6ac 100644
--- a/src/Persistent_cohomology/test/CMakeLists.txt
+++ b/src/Persistent_cohomology/test/CMakeLists.txt
@@ -37,4 +37,3 @@ if(GMPXX_FOUND AND GMP_FOUND)
endif()
-cpplint_add_tests("${CMAKE_SOURCE_DIR}/src/Persistent_cohomology/include/gudhi")
diff --git a/src/Simplex_tree/test/CMakeLists.txt b/src/Simplex_tree/test/CMakeLists.txt
index 1563d082..b6a1c0b6 100644
--- a/src/Simplex_tree/test/CMakeLists.txt
+++ b/src/Simplex_tree/test/CMakeLists.txt
@@ -23,4 +23,3 @@ add_test(NAME SimplexTreeUT
# XML format for Jenkins xUnit plugin
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/SimplexTreeUT.xml --log_level=test_suite --report_level=no)
-cpplint_add_tests("${CMAKE_SOURCE_DIR}/src/Simplex_tree/include/gudhi")
diff --git a/src/Skeleton_blocker/test/CMakeLists.txt b/src/Skeleton_blocker/test/CMakeLists.txt
index f9b3de91..e62600a2 100644
--- a/src/Skeleton_blocker/test/CMakeLists.txt
+++ b/src/Skeleton_blocker/test/CMakeLists.txt
@@ -22,4 +22,3 @@ add_test(TestSkeletonBlockerComplex ${CMAKE_CURRENT_BINARY_DIR}/TestSkeletonBloc
add_test(TestSimplifiable ${CMAKE_CURRENT_BINARY_DIR}/TestSimplifiable)
add_test(TestGeometricComplex ${CMAKE_CURRENT_BINARY_DIR}/TestGeometricComplex)
-cpplint_add_tests("${CMAKE_SOURCE_DIR}/src/Skeleton_blocker/include/gudhi")