summaryrefslogtreecommitdiff
path: root/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..d451e683
--- /dev/null
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,88 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:12:45 +0200
+Subject: Disable tests that use DFSG-deleted data files.
+
+---
+ src/Nerve_GIC/example/CMakeLists.txt | 5 -----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 --------
+ src/python/CMakeLists.txt | 29 -----------------------------
+ 3 files changed, 42 deletions(-)
+
+diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
+index 4b0f467..110212d 100644
+--- a/src/Nerve_GIC/example/CMakeLists.txt
++++ b/src/Nerve_GIC/example/CMakeLists.txt
+@@ -12,14 +12,9 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
+index 65a08d9..3f16db9 100644
+--- a/src/Nerve_GIC/utilities/CMakeLists.txt
++++ b/src/Nerve_GIC/utilities/CMakeLists.txt
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 5f32393..02082db 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -432,35 +432,6 @@ if(PYTHONINTERP_FOUND)
+
+ add_gudhi_py_test(test_bottleneck_distance)
+
+- # Cover complex
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- add_test(NAME cover_complex_nerve_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
+- -f human.off -c 2 -r 10 -g 0.3)
+-
+- add_test(NAME cover_complex_coordinate_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
+- -f human.off -c 0 -v)
+-
+- add_test(NAME cover_complex_functional_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
+- -o lucky_cat.off
+- -f lucky_cat_PCA1 -v)
+-
+- add_test(NAME cover_complex_voronoi_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
+- -f human.off -n 700 -v)
+-
+ add_gudhi_py_test(test_cover_complex)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+