summaryrefslogtreecommitdiff
path: root/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch')
-rw-r--r--debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
new file mode 100644
index 00000000..cd17e0f1
--- /dev/null
+++ b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
@@ -0,0 +1,28 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 12:05:01 +0200
+Subject: [PATCH 2/5] Disable the Sphinx test. We're not using it,
+ as it requires the Sphinx bibtex module (#800358).
+
+---
+ cython/CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index afca9d6..ec3cb8f 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -305,10 +305,10 @@ if(CYTHON_FOUND)
+ DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/gudhi.so"
+ COMMENT "${GUDHI_SPHINX_MESSAGE}" VERBATIM)
+
+- add_test(NAME sphinx_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
++# add_test(NAME sphinx_py_test
++# WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
++# COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
++# ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
+
+ endif(SPHINX_PATH AND NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ endif(CYTHON_FOUND)