summaryrefslogtreecommitdiff
path: root/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch')
-rw-r--r--debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
new file mode 100644
index 00000000..9f4c6412
--- /dev/null
+++ b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
@@ -0,0 +1,22 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 16 Oct 2017 13:46:22 +0200
+Subject: [PATCH 5/5] Don't set runtime_library_dirs for the Python extension.
+ Avoid RPATH in the shared object.
+
+---
+ cython/setup.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/setup.py.in b/cython/setup.py.in
+index c767e93..d00f65a 100644
+--- a/cython/setup.py.in
++++ b/cython/setup.py.in
+@@ -36,7 +36,7 @@ gudhi = Extension(
+ libraries=[@GUDHI_CYTHON_LIBRARIES@],
+ library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
+ include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
+- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
++ runtime_library_dirs=[],
+ )
+
+ setup(