summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch121
-rw-r--r--debian/patches/0002-Use-system-MathJax.patch21
-rw-r--r--debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch21
-rw-r--r--debian/patches/0004-Offline-header-for-docs.patch21
-rw-r--r--debian/patches/0005-Disable-Sphinx.patch20
-rw-r--r--debian/patches/0006-Install-Python-module-in-correct-location.patch21
-rw-r--r--debian/patches/0007-Move-towards-reproducible-builds.patch24
-rw-r--r--debian/patches/series7
8 files changed, 256 insertions, 0 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..82a72911
--- /dev/null
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,121 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:12:45 +0200
+Subject: Disable tests that use DFSG-deleted data files.
+
+---
+ src/Nerve_GIC/example/CMakeLists.txt | 5 ----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
+ src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
+ src/Simplex_tree/example/CMakeLists.txt | 2 --
+ src/python/CMakeLists.txt | 31 +-----------------------
+ 5 files changed, 1 insertion(+), 49 deletions(-)
+
+diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
+index 1667472..37c4759 100644
+--- a/src/Nerve_GIC/example/CMakeLists.txt
++++ b/src/Nerve_GIC/example/CMakeLists.txt
+@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ install(TARGETS CoordGIC DESTINATION bin)
+ install(TARGETS FuncGIC DESTINATION bin)
+diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
+index 65a08d9..3f16db9 100644
+--- a/src/Nerve_GIC/utilities/CMakeLists.txt
++++ b/src/Nerve_GIC/utilities/CMakeLists.txt
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
+index 94ec13c..4a48d21 100644
+--- a/src/Persistent_cohomology/example/CMakeLists.txt
++++ b/src/Persistent_cohomology/example/CMakeLists.txt
+@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
+index f99b164..ae302dc 100644
+--- a/src/Simplex_tree/example/CMakeLists.txt
++++ b/src/Simplex_tree/example/CMakeLists.txt
+@@ -25,8 +25,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ endif()
+
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 5508cbc..1778290 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -256,36 +256,7 @@ if(PYTHONINTERP_FOUND)
+
+ add_gudhi_py_test(test_bottleneck_distance)
+
+- # Cover complex
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- add_test(NAME cover_complex_nerve_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
+- -f human.off -c 2 -r 10 -g 0.3)
+-
+- add_test(NAME cover_complex_coordinate_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
+- -f human.off -c 0 -v)
+-
+- add_test(NAME cover_complex_functional_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
+- -o lucky_cat.off
+- -f lucky_cat_PCA1 -v)
+-
+- add_test(NAME cover_complex_voronoi_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
+- -f human.off -n 700 -v)
+-
+- add_gudhi_py_test(test_cover_complex)
++
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/debian/patches/0002-Use-system-MathJax.patch b/debian/patches/0002-Use-system-MathJax.patch
new file mode 100644
index 00000000..fd6288ba
--- /dev/null
+++ b/debian/patches/0002-Use-system-MathJax.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:14:13 +0200
+Subject: Use system MathJax.
+
+---
+ src/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Doxyfile.in b/src/Doxyfile.in
+index 5777549..de452c9 100644
+--- a/src/Doxyfile.in
++++ b/src/Doxyfile.in
+@@ -1440,7 +1440,7 @@ MATHJAX_FORMAT = HTML-CSS
+ # The default value is: http://cdn.mathjax.org/mathjax/latest.
+ # This tag requires that the tag USE_MATHJAX is set to YES.
+
+-MATHJAX_RELPATH = https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.2
++MATHJAX_RELPATH = /usr/share/javascript/mathjax
+
+ # The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
+ # extension names that should be enabled during MathJax rendering. For example
diff --git a/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch b/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
new file mode 100644
index 00000000..0a20ce1e
--- /dev/null
+++ b/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:18:08 +0200
+Subject: Force linking against libatomic for parts that use TBB.
+
+---
+ src/cmake/modules/FindTBB.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/cmake/modules/FindTBB.cmake b/src/cmake/modules/FindTBB.cmake
+index 13f4d92..6baa8d7 100644
+--- a/src/cmake/modules/FindTBB.cmake
++++ b/src/cmake/modules/FindTBB.cmake
+@@ -375,6 +375,8 @@ if (TBB_INCLUDE_DIR)
+ endif(NOT TBB_without_pthread)
+ endif(UNIX AND NOT APPLE)
+
++ list(APPEND ALL_TBB_LIBRARIES atomic)
++
+ set (TBB_LIBRARIES ${ALL_TBB_LIBRARIES}
+ CACHE PATH "TBB libraries" FORCE)
+
diff --git a/debian/patches/0004-Offline-header-for-docs.patch b/debian/patches/0004-Offline-header-for-docs.patch
new file mode 100644
index 00000000..232d7e53
--- /dev/null
+++ b/debian/patches/0004-Offline-header-for-docs.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:19:14 +0200
+Subject: Offline header for docs.
+
+---
+ src/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Doxyfile.in b/src/Doxyfile.in
+index de452c9..98d8b96 100644
+--- a/src/Doxyfile.in
++++ b/src/Doxyfile.in
+@@ -1045,7 +1045,7 @@ HTML_FILE_EXTENSION = .html
+ # of the possible markers and block names see the documentation.
+ # This tag requires that the tag GENERATE_HTML is set to YES.
+
+-HTML_HEADER = doc/common/header.html
++HTML_HEADER = doc/common/offline_header.html
+
+ # The HTML_FOOTER tag can be used to specify a user-defined HTML footer for each
+ # generated HTML page. If the tag is left blank doxygen will generate a standard
diff --git a/debian/patches/0005-Disable-Sphinx.patch b/debian/patches/0005-Disable-Sphinx.patch
new file mode 100644
index 00000000..e3f42382
--- /dev/null
+++ b/debian/patches/0005-Disable-Sphinx.patch
@@ -0,0 +1,20 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:28:15 +0200
+Subject: Disable Sphinx.
+
+---
+ src/cmake/modules/GUDHI_third_party_libraries.cmake | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+index 360a230..bffd2ee 100644
+--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
++++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+@@ -124,7 +124,6 @@ if( PYTHONINTERP_FOUND )
+ find_python_module("matplotlib")
+ find_python_module("numpy")
+ find_python_module("scipy")
+- find_python_module("sphinx")
+ endif()
+
+ if(NOT GUDHI_PYTHON_PATH)
diff --git a/debian/patches/0006-Install-Python-module-in-correct-location.patch b/debian/patches/0006-Install-Python-module-in-correct-location.patch
new file mode 100644
index 00000000..67999267
--- /dev/null
+++ b/debian/patches/0006-Install-Python-module-in-correct-location.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Thu, 26 Sep 2019 13:26:22 +0200
+Subject: Install Python module in correct location.
+
+---
+ src/python/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 1778290..a999cea 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -208,7 +208,7 @@ if(PYTHONINTERP_FOUND)
+ add_custom_target(python ALL DEPENDS gudhi.so
+ COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
+
+- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
++ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install --root=${CMAKE_SOURCE_DIR}/debian/tmp --single-version-externally-managed --install-layout=deb WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})")
+
+ # Test examples
+ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/debian/patches/0007-Move-towards-reproducible-builds.patch b/debian/patches/0007-Move-towards-reproducible-builds.patch
new file mode 100644
index 00000000..4c487bab
--- /dev/null
+++ b/debian/patches/0007-Move-towards-reproducible-builds.patch
@@ -0,0 +1,24 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Tue, 10 Dec 2019 14:31:47 +0100
+Subject: Move towards reproducible builds.
+
+This probably does not take us all the way there, and probably breaks
+doctest, but since we're not doing sphinx stuff yet anyway, that is ok
+for now.
+---
+ src/python/gudhi/__init__.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/gudhi/__init__.py.in b/src/python/gudhi/__init__.py.in
+index 28bab0e..e22dde4 100644
+--- a/src/python/gudhi/__init__.py.in
++++ b/src/python/gudhi/__init__.py.in
+@@ -15,7 +15,7 @@ __copyright__ = "Copyright (C) 2016 Inria"
+ __license__ = "https://gudhi.inria.fr/licensing/"
+ __version__ = "@GUDHI_VERSION@"
+ # This variable is used by doctest to find files
+-__root_source_dir__ = "@CMAKE_SOURCE_DIR@"
++__root_source_dir__ = "."
+ __debug_info__ = @GUDHI_PYTHON_DEBUG_INFO@
+
+ from sys import exc_info
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..adeb35f7
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,7 @@
+0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+0002-Use-system-MathJax.patch
+0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
+0004-Offline-header-for-docs.patch
+0005-Disable-Sphinx.patch
+0006-Install-Python-module-in-correct-location.patch
+0007-Move-towards-reproducible-builds.patch