summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch88
-rw-r--r--debian/patches/0002-Use-system-MathJax.patch21
-rw-r--r--debian/patches/0003-Offline-header-for-docs.patch21
-rw-r--r--debian/patches/0004-Disable-Sphinx.patch20
-rw-r--r--debian/patches/0005-Don-t-process-the-entire-source-tree-with-Doxygen.patch21
-rw-r--r--debian/patches/0006-CGAL-5.5-compatibility.patch78
-rw-r--r--debian/patches/series6
7 files changed, 255 insertions, 0 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..82abd0ed
--- /dev/null
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,88 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:12:45 +0200
+Subject: Disable tests that use DFSG-deleted data files.
+
+---
+ src/Nerve_GIC/example/CMakeLists.txt | 5 -----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 --------
+ src/python/CMakeLists.txt | 29 -----------------------------
+ 3 files changed, 42 deletions(-)
+
+diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
+index 4b0f467..110212d 100644
+--- a/src/Nerve_GIC/example/CMakeLists.txt
++++ b/src/Nerve_GIC/example/CMakeLists.txt
+@@ -12,14 +12,9 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
+index 65a08d9..3f16db9 100644
+--- a/src/Nerve_GIC/utilities/CMakeLists.txt
++++ b/src/Nerve_GIC/utilities/CMakeLists.txt
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 1314b44..7edac67 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -414,35 +414,6 @@ if(PYTHONINTERP_FOUND)
+
+ add_gudhi_py_test(test_bottleneck_distance)
+
+- # Cover complex
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- add_test(NAME cover_complex_nerve_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
+- -f human.off -c 2 -r 10 -g 0.3)
+-
+- add_test(NAME cover_complex_coordinate_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
+- -f human.off -c 0 -v)
+-
+- add_test(NAME cover_complex_functional_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
+- -o lucky_cat.off
+- -f lucky_cat_PCA1 -v)
+-
+- add_test(NAME cover_complex_voronoi_gic_example_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
+- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
+- -f human.off -n 700 -v)
+-
+ add_gudhi_py_test(test_cover_complex)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
diff --git a/debian/patches/0002-Use-system-MathJax.patch b/debian/patches/0002-Use-system-MathJax.patch
new file mode 100644
index 00000000..8123a42d
--- /dev/null
+++ b/debian/patches/0002-Use-system-MathJax.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:14:13 +0200
+Subject: Use system MathJax.
+
+---
+ src/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Doxyfile.in b/src/Doxyfile.in
+index ae8db1a..9f697a5 100644
+--- a/src/Doxyfile.in
++++ b/src/Doxyfile.in
+@@ -1526,7 +1526,7 @@ MATHJAX_FORMAT = HTML-CSS
+ # The default value is: http://cdn.mathjax.org/mathjax/latest.
+ # This tag requires that the tag USE_MATHJAX is set to YES.
+
+-MATHJAX_RELPATH = https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.2
++MATHJAX_RELPATH = /usr/share/javascript/mathjax
+
+ # The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
+ # extension names that should be enabled during MathJax rendering. For example
diff --git a/debian/patches/0003-Offline-header-for-docs.patch b/debian/patches/0003-Offline-header-for-docs.patch
new file mode 100644
index 00000000..01b58c29
--- /dev/null
+++ b/debian/patches/0003-Offline-header-for-docs.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:19:14 +0200
+Subject: Offline header for docs.
+
+---
+ src/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Doxyfile.in b/src/Doxyfile.in
+index 9f697a5..4b6d792 100644
+--- a/src/Doxyfile.in
++++ b/src/Doxyfile.in
+@@ -1127,7 +1127,7 @@ HTML_FILE_EXTENSION = .html
+ # of the possible markers and block names see the documentation.
+ # This tag requires that the tag GENERATE_HTML is set to YES.
+
+-HTML_HEADER = @GUDHI_DOXYGEN_COMMON_DOC_PATH@/header.html
++HTML_HEADER = @GUDHI_DOXYGEN_COMMON_DOC_PATH@/offline_header.html
+
+ # The HTML_FOOTER tag can be used to specify a user-defined HTML footer for each
+ # generated HTML page. If the tag is left blank doxygen will generate a standard
diff --git a/debian/patches/0004-Disable-Sphinx.patch b/debian/patches/0004-Disable-Sphinx.patch
new file mode 100644
index 00000000..de66bbfb
--- /dev/null
+++ b/debian/patches/0004-Disable-Sphinx.patch
@@ -0,0 +1,20 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Tue, 21 Jan 2020 10:36:48 +0100
+Subject: Disable Sphinx.
+
+---
+ src/cmake/modules/GUDHI_third_party_libraries.cmake | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+index 21c9d47..d22697c 100644
+--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
++++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+@@ -148,7 +148,6 @@ if( PYTHONINTERP_FOUND )
+ find_python_module("matplotlib")
+ find_python_module("numpy")
+ find_python_module("scipy")
+- find_python_module("sphinx")
+ find_python_module("sklearn")
+ find_python_module("ot")
+ find_python_module("pybind11")
diff --git a/debian/patches/0005-Don-t-process-the-entire-source-tree-with-Doxygen.patch b/debian/patches/0005-Don-t-process-the-entire-source-tree-with-Doxygen.patch
new file mode 100644
index 00000000..bb9c622d
--- /dev/null
+++ b/debian/patches/0005-Don-t-process-the-entire-source-tree-with-Doxygen.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Fri, 14 Jan 2022 19:28:15 +0100
+Subject: Don't process the entire source tree with Doxygen
+
+---
+ src/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Doxyfile.in b/src/Doxyfile.in
+index 4b6d792..8b38967 100644
+--- a/src/Doxyfile.in
++++ b/src/Doxyfile.in
+@@ -783,7 +783,7 @@ WARN_LOGFILE =
+ # spaces. See also FILE_PATTERNS and EXTENSION_MAPPING
+ # Note: If this tag is empty the current directory is searched.
+
+-INPUT = @CMAKE_SOURCE_DIR@
++INPUT =
+
+ # This tag can be used to specify the character encoding of the source files
+ # that doxygen parses. Internally doxygen uses the UTF-8 encoding. Doxygen uses
diff --git a/debian/patches/0006-CGAL-5.5-compatibility.patch b/debian/patches/0006-CGAL-5.5-compatibility.patch
new file mode 100644
index 00000000..a5d28944
--- /dev/null
+++ b/debian/patches/0006-CGAL-5.5-compatibility.patch
@@ -0,0 +1,78 @@
+From: Vincent Rouvreau <vincent.rouvreau@inria.fr>
+Date: Tue, 9 Aug 2022 16:06:06 +0200
+Subject: CGAL 5.5 compatibility
+
+Based on upstream commits
+
+ dc7a0aed53d7b74580ed5625293e27cacd452c34
+ 71cbf8f35814d247fe7421c079a6ea78da2282f4
+
+with modifications from discussion in
+
+ https://github.com/CGAL/cgal/issues/6799
+---
+ .../include/gudhi/Skeleton_blocker_contractor.h | 21 ++++++++++++++++-----
+ 1 file changed, 16 insertions(+), 5 deletions(-)
+
+diff --git a/src/Contraction/include/gudhi/Skeleton_blocker_contractor.h b/src/Contraction/include/gudhi/Skeleton_blocker_contractor.h
+index a0d9f2b..d510043 100644
+--- a/src/Contraction/include/gudhi/Skeleton_blocker_contractor.h
++++ b/src/Contraction/include/gudhi/Skeleton_blocker_contractor.h
+@@ -171,8 +171,13 @@ typename GeometricSimplifiableComplex::Vertex_handle> {
+ Self const* algorithm_;
+ };
+
++#if CGAL_VERSION_NR < 1050500000
+ typedef CGAL::Modifiable_priority_queue<Edge_handle, Compare_cost, Undirected_edge_id> PQ;
+- typedef typename PQ::handle pq_handle;
++#else
++ typedef CGAL::Modifiable_priority_queue<Edge_handle, Compare_cost, Undirected_edge_id, CGAL::CGAL_BOOST_PAIRING_HEAP> PQ;
++#endif
++
++ typedef bool pq_handle;
+
+
+ // An Edge_data is associated with EVERY edge in the complex (collapsible or not).
+@@ -196,7 +201,7 @@ typename GeometricSimplifiableComplex::Vertex_handle> {
+ }
+
+ bool is_in_PQ() const {
+- return PQHandle_ != PQ::null_handle();
++ return PQHandle_ != false;
+ }
+
+ void set_PQ_handle(pq_handle h) {
+@@ -204,7 +209,7 @@ typename GeometricSimplifiableComplex::Vertex_handle> {
+ }
+
+ void reset_PQ_handle() {
+- PQHandle_ = PQ::null_handle();
++ PQHandle_ = false;
+ }
+
+ private:
+@@ -238,16 +243,22 @@ typename GeometricSimplifiableComplex::Vertex_handle> {
+ }
+
+ void insert_in_PQ(Edge_handle edge, Edge_data& data) {
+- data.set_PQ_handle(heap_PQ_->push(edge));
++ heap_PQ_->push(edge);
++ data.set_PQ_handle(true);
+ ++current_num_edges_heap_;
+ }
+
+ void update_in_PQ(Edge_handle edge, Edge_data& data) {
++#if CGAL_VERSION_NR < 1050500000
+ data.set_PQ_handle(heap_PQ_->update(edge, data.PQ_handle()));
++#else
++ heap_PQ_->update(edge);
++#endif
+ }
+
+ void remove_from_PQ(Edge_handle edge, Edge_data& data) {
+- data.set_PQ_handle(heap_PQ_->erase(edge, data.PQ_handle()));
++ heap_PQ_->erase(edge);
++ data.set_PQ_handle(false);
+ --current_num_edges_heap_;
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..5c95e702
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,6 @@
+0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+0002-Use-system-MathJax.patch
+0003-Offline-header-for-docs.patch
+0004-Disable-Sphinx.patch
+0005-Don-t-process-the-entire-source-tree-with-Doxygen.patch
+0006-CGAL-5.5-compatibility.patch