summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch36
-rw-r--r--debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch32
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch63
-rw-r--r--debian/patches/0004-Use-system-MathJax.patch25
-rw-r--r--debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch26
-rw-r--r--debian/patches/series5
6 files changed, 187 insertions, 0 deletions
diff --git a/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch b/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
new file mode 100644
index 00000000..b6e05ed7
--- /dev/null
+++ b/debian/patches/0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
@@ -0,0 +1,36 @@
+From e92363ab8125cff24a9c2ef5eec159ff09afc381 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 11:46:06 +0200
+Subject: [PATCH 1/4] Force Python 3 detection to avoid mixing 2 and 3.
+
+---
+ cmake/modules/FindCython.cmake | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/modules/FindCython.cmake b/cmake/modules/FindCython.cmake
+index 04aed1f..f3a5b7b 100644
+--- a/cmake/modules/FindCython.cmake
++++ b/cmake/modules/FindCython.cmake
+@@ -24,16 +24,16 @@
+
+ # Use the Cython executable that lives next to the Python executable
+ # if it is a local installation.
+-find_package( PythonInterp )
++find_package( PythonInterp 3 )
+ if( PYTHONINTERP_FOUND )
+ get_filename_component( _python_path ${PYTHON_EXECUTABLE} PATH )
+ find_program( CYTHON_EXECUTABLE
+- NAMES cython cython.bat cython3
++ NAMES cython3
+ HINTS ${_python_path}
+ )
+ else()
+ find_program( CYTHON_EXECUTABLE
+- NAMES cython cython.bat cython3
++ NAMES cython3
+ )
+ endif()
+
+--
+2.11.0
+
diff --git a/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
new file mode 100644
index 00000000..2eb76f06
--- /dev/null
+++ b/debian/patches/0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
@@ -0,0 +1,32 @@
+From 2511e115a28311263e7ed85e98296c6af12ea960 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 12:05:01 +0200
+Subject: [PATCH 2/4] Disable the Sphinx test. We're not using it, as it
+ requires the Sphinx bibtex module (#800358).
+
+---
+ cython/CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index afca9d6..ec3cb8f 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -305,10 +305,10 @@ if(CYTHON_FOUND)
+ DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/gudhi.so"
+ COMMENT "${GUDHI_SPHINX_MESSAGE}" VERBATIM)
+
+- add_test(NAME sphinx_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
++# add_test(NAME sphinx_py_test
++# WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
++# COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
++# ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
+
+ endif(SPHINX_PATH AND NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ endif(CYTHON_FOUND)
+--
+2.11.0
+
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..eade3da7
--- /dev/null
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,63 @@
+From f31347031ea99c60d11064ec28bc27805b5c28b9 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 14:15:02 +0200
+Subject: [PATCH 3/4] Disable tests that use DFSG-deleted data files.
+
+---
+ example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
+ example/Simplex_tree/CMakeLists.txt | 4 ++--
+ example/common/CMakeLists.txt | 4 ++--
+ 3 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
+index f47de4c..8f11ea0 100644
+--- a/example/Persistent_cohomology/CMakeLists.txt
++++ b/example/Persistent_cohomology/CMakeLists.txt
+@@ -41,10 +41,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
++#add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
++# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
++#add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
++# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
+index e22cc92..99da80f 100644
+--- a/example/Simplex_tree/CMakeLists.txt
++++ b/example/Simplex_tree/CMakeLists.txt
+@@ -30,8 +30,8 @@ if(GMP_FOUND AND CGAL_FOUND)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
++# add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
++# "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
+
+diff --git a/example/common/CMakeLists.txt b/example/common/CMakeLists.txt
+index afe865d..2ad4a64 100644
+--- a/example/common/CMakeLists.txt
++++ b/example/common/CMakeLists.txt
+@@ -3,8 +3,8 @@ project(Common_examples)
+
+ add_executable ( vector_double_off_reader example_vector_double_points_off_reader.cpp )
+ target_link_libraries(vector_double_off_reader ${CGAL_LIBRARY})
+-add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
+- "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
++#add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
++# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
+
+ install(TARGETS vector_double_off_reader DESTINATION bin)
+
+--
+2.11.0
+
diff --git a/debian/patches/0004-Use-system-MathJax.patch b/debian/patches/0004-Use-system-MathJax.patch
new file mode 100644
index 00000000..916d23b9
--- /dev/null
+++ b/debian/patches/0004-Use-system-MathJax.patch
@@ -0,0 +1,25 @@
+From 46fdbaf1a91c320d7f731d061ef6d8d6da73232a Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 16:06:36 +0200
+Subject: [PATCH 4/4] Use system MathJax.
+
+---
+ Doxyfile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Doxyfile b/Doxyfile
+index 0ef81e5..51df82e 100644
+--- a/Doxyfile
++++ b/Doxyfile
+@@ -1450,7 +1450,7 @@ MATHJAX_FORMAT = HTML-CSS
+ # The default value is: http://cdn.mathjax.org/mathjax/latest.
+ # This tag requires that the tag USE_MATHJAX is set to YES.
+
+-MATHJAX_RELPATH = ../common
++MATHJAX_RELPATH = /usr/share/javascript/mathjax
+
+ # The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
+ # extension names that should be enabled during MathJax rendering. For example
+--
+2.11.0
+
diff --git a/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
new file mode 100644
index 00000000..c5677149
--- /dev/null
+++ b/debian/patches/0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch
@@ -0,0 +1,26 @@
+From 2dfc0e89fdf40fe474ef0ec2018fe06e5eb786d5 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 16 Oct 2017 13:46:22 +0200
+Subject: [PATCH] Don't set runtime_library_dirs for the Python extension.
+ Avoid RPATH in the shared object.
+
+---
+ cython/setup.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/setup.py.in b/cython/setup.py.in
+index fefa36b..18d03ad 100644
+--- a/cython/setup.py.in
++++ b/cython/setup.py.in
+@@ -36,7 +36,7 @@ gudhi = Extension(
+ libraries=[@GUDHI_CYTHON_LIBRARIES@],
+ library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
+ include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
+- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
++ runtime_library_dirs=[],
+ )
+
+ setup(
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 00000000..cd9fa866
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,5 @@
+0001-Force-Python-3-detection-to-avoid-mixing-2-and-3.patch
+0002-Disable-the-Sphinx-test.-We-re-not-using-it-as-it-re.patch
+0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+0004-Use-system-MathJax.patch
+0005-Don-t-set-runtime_library_dirs-for-the-Python-extens.patch