summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test
diff options
context:
space:
mode:
Diffstat (limited to 'src/Alpha_complex/test')
-rw-r--r--src/Alpha_complex/test/Alpha_complex_unit_test.cpp4
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt4
2 files changed, 6 insertions, 2 deletions
diff --git a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
index b630e999..5633d2c7 100644
--- a/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
+++ b/src/Alpha_complex/test/Alpha_complex_unit_test.cpp
@@ -46,7 +46,7 @@ BOOST_AUTO_TEST_CASE(ALPHA_DOC_OFF_file) {
// Init of an alpha-complex from a OFF file
//
// ----------------------------------------------------------------------------
- std::string off_file_name("../../../data/points/alphacomplexdoc.off");
+ std::string off_file_name("alphacomplexdoc.off");
double max_alpha_square_value = 60.0;
std::cout << "========== OFF FILE NAME = " << off_file_name << " - alpha²=" <<
max_alpha_square_value << "==========" << std::endl;
@@ -73,7 +73,7 @@ BOOST_AUTO_TEST_CASE(ALPHA_DOC_OFF_file_filtered) {
// Init of an alpha-complex from a OFF file
//
// ----------------------------------------------------------------------------
- std::string off_file_name("../../../data/points/alphacomplexdoc.off");
+ std::string off_file_name("alphacomplexdoc.off");
double max_alpha_square_value = 59.0;
std::cout << "========== OFF FILE NAME = " << off_file_name << " - alpha²=" <<
max_alpha_square_value << "==========" << std::endl;
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index 87b05a3a..847581aa 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -21,6 +21,10 @@ if(CGAL_FOUND)
add_executable ( AlphaComplexUT Alpha_complex_unit_test.cpp )
target_link_libraries(AlphaComplexUT ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
+ # Do not forget to copy test files in current binary dir
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
add_test(AlphaComplexUT ${CMAKE_CURRENT_BINARY_DIR}/AlphaComplexUT
# XML format for Jenkins xUnit plugin
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/AlphaComplexUT.xml --log_level=test_suite --report_level=no)