summaryrefslogtreecommitdiff
path: root/src/Alpha_complex
diff options
context:
space:
mode:
Diffstat (limited to 'src/Alpha_complex')
-rw-r--r--src/Alpha_complex/doc/Intro_alpha_complex.h8
-rw-r--r--src/Alpha_complex/example/CMakeLists.txt10
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt3
3 files changed, 14 insertions, 7 deletions
diff --git a/src/Alpha_complex/doc/Intro_alpha_complex.h b/src/Alpha_complex/doc/Intro_alpha_complex.h
index 9d0dcefa..226bb257 100644
--- a/src/Alpha_complex/doc/Intro_alpha_complex.h
+++ b/src/Alpha_complex/doc/Intro_alpha_complex.h
@@ -65,7 +65,7 @@ namespace alphacomplex {
*
* Then, it is asked to display information about the alpha complex.
*
- * \include Alpha_complex_from_points.cpp
+ * \include Alpha_complex/Alpha_complex_from_points.cpp
*
* When launching:
*
@@ -74,7 +74,7 @@ namespace alphacomplex {
*
* the program output is:
*
- * \include alphaoffreader_for_doc_60.txt
+ * \include Alpha_complex/alphaoffreader_for_doc_60.txt
*
* \section algorithm Algorithm
*
@@ -145,7 +145,7 @@ namespace alphacomplex {
*
* Then, it is asked to display information about the alpha complex.
*
- * \include Alpha_complex_from_off.cpp
+ * \include Alpha_complex/Alpha_complex_from_off.cpp
*
* When launching:
*
@@ -154,7 +154,7 @@ namespace alphacomplex {
*
* the program output is:
*
- * \include alphaoffreader_for_doc_32.txt
+ * \include Alpha_complex/alphaoffreader_for_doc_32.txt
*
* \copyright GNU General Public License v3.
* \verbatim Contact: gudhi-users@lists.gforge.inria.fr \endverbatim
diff --git a/src/Alpha_complex/example/CMakeLists.txt b/src/Alpha_complex/example/CMakeLists.txt
index debb440d..f1346867 100644
--- a/src/Alpha_complex/example/CMakeLists.txt
+++ b/src/Alpha_complex/example/CMakeLists.txt
@@ -14,12 +14,16 @@ if(CGAL_FOUND)
add_executable ( alphapoints Alpha_complex_from_points.cpp )
target_link_libraries(alphapoints ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
- add_test(alphapoints ${CMAKE_CURRENT_BINARY_DIR}/alphapoints)
+ add_executable ( alphaoffreader Alpha_complex_from_off.cpp )
+ target_link_libraries(alphaoffreader ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(alphapoints ${TBB_RELEASE_LIBRARY})
+ target_link_libraries(alphaoffreader ${TBB_RELEASE_LIBRARY})
+ endif()
+ add_test(alphapoints ${CMAKE_CURRENT_BINARY_DIR}/alphapoints)
# Do not forget to copy test files in current binary dir
file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- add_executable ( alphaoffreader Alpha_complex_from_off.cpp )
- target_link_libraries(alphaoffreader ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
add_test(alphaoffreader_doc_60 ${CMAKE_CURRENT_BINARY_DIR}/alphaoffreader alphacomplexdoc.off 60.0 ${CMAKE_CURRENT_BINARY_DIR}/alphaoffreader_result_60.txt)
add_test(alphaoffreader_doc_32 ${CMAKE_CURRENT_BINARY_DIR}/alphaoffreader alphacomplexdoc.off 32.0 ${CMAKE_CURRENT_BINARY_DIR}/alphaoffreader_result_32.txt)
if (DIFF_PATH)
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index 2e5d6c3d..e24588d7 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -24,6 +24,9 @@ if(CGAL_FOUND)
add_executable ( AlphaComplexUT Alpha_complex_unit_test.cpp )
target_link_libraries(AlphaComplexUT ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(AlphaComplexUT ${TBB_RELEASE_LIBRARY})
+ endif()
# Do not forget to copy test files in current binary dir
file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)