summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance
diff options
context:
space:
mode:
Diffstat (limited to 'src/Bottleneck_distance')
-rw-r--r--src/Bottleneck_distance/example/README4
-rw-r--r--src/Bottleneck_distance/utilities/CMakeLists.txt8
-rw-r--r--src/Bottleneck_distance/utilities/bottleneck_distance.cpp (renamed from src/Bottleneck_distance/utilities/bottleneck_read_file.cpp)0
3 files changed, 6 insertions, 6 deletions
diff --git a/src/Bottleneck_distance/example/README b/src/Bottleneck_distance/example/README
index 0e314608..01bcd74a 100644
--- a/src/Bottleneck_distance/example/README
+++ b/src/Bottleneck_distance/example/README
@@ -3,9 +3,9 @@
## `alpha_rips_persistence_bottleneck_distance` ##
This program computes the persistent homology with coefficient field Z/pZ of a Rips complex defined on a set of input points. The output diagram contains one bar per line, written with the convention:
-`p dim b d`
+`p dim birth death`
-where `dim` is the dimension of the homological feature, `b` and `d` are respectively the birth and death of the feature, and `p` is the characteristic of the field *Z/pZ* used for homology coefficients.
+where `dim` is the dimension of the homological feature, `birth` and `death` are respectively the birth and death of the feature, and `p` is the characteristic of the field *Z/pZ* used for homology coefficients.
Usage:
`alpha_rips_persistence_bottleneck_distance [options] <OFF input file>`
diff --git a/src/Bottleneck_distance/utilities/CMakeLists.txt b/src/Bottleneck_distance/utilities/CMakeLists.txt
index 063b6ae3..d19e3b1c 100644
--- a/src/Bottleneck_distance/utilities/CMakeLists.txt
+++ b/src/Bottleneck_distance/utilities/CMakeLists.txt
@@ -2,15 +2,15 @@ cmake_minimum_required(VERSION 2.6)
project(Bottleneck_distance_utilities)
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable (bottleneck_read_file bottleneck_read_file.cpp)
+ add_executable (bottleneck_distance bottleneck_distance.cpp)
if (TBB_FOUND)
- target_link_libraries(bottleneck_read_file ${TBB_LIBRARIES})
+ target_link_libraries(bottleneck_distance ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(NAME Bottleneck_distance_utilities_Bottleneck_read_file
- COMMAND $<TARGET_FILE:bottleneck_read_file>
+ COMMAND $<TARGET_FILE:bottleneck_distance>
"${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
- install(TARGETS bottleneck_read_file DESTINATION bin)
+ install(TARGETS bottleneck_distance DESTINATION bin)
endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
diff --git a/src/Bottleneck_distance/utilities/bottleneck_read_file.cpp b/src/Bottleneck_distance/utilities/bottleneck_distance.cpp
index 9dd52b31..9dd52b31 100644
--- a/src/Bottleneck_distance/utilities/bottleneck_read_file.cpp
+++ b/src/Bottleneck_distance/utilities/bottleneck_distance.cpp