summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ebdcdcea..7ab2a883 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -90,6 +90,8 @@ else()
add_definitions(-DBOOST_RESULT_OF_USE_DECLTYPE)
# BOOST ISSUE with Libraries name resolution under Windows
add_definitions(-DBOOST_ALL_NO_LIB)
+ # problem with Visual Studio link on Boost program_options
+ add_definitions( -DBOOST_ALL_DYN_LINK )
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
@@ -125,6 +127,10 @@ else()
# Please let GudhUI in last compilation position as QT is known to modify CMAKE_CXX_FLAGS
# GudhUI
add_subdirectory(GudhUI)
+
+ # This variable is used by Cython CMakeLists.txt to know its path
+ set(GUDHI_CYTHON_PATH "cython")
+ add_subdirectory(${GUDHI_CYTHON_PATH})
#---------------------------------------------------------------------------------------
#---------------------------------------------------------------------------------------