summaryrefslogtreecommitdiff
path: root/src/Gudhi_stat/example
diff options
context:
space:
mode:
Diffstat (limited to 'src/Gudhi_stat/example')
-rw-r--r--src/Gudhi_stat/example/CMakeLists.txt21
-rw-r--r--src/Gudhi_stat/example/persistence_heat_maps.cpp93
-rw-r--r--src/Gudhi_stat/example/persistence_intervals.cpp111
-rw-r--r--src/Gudhi_stat/example/persistence_landscape.cpp92
-rw-r--r--src/Gudhi_stat/example/persistence_landscape_on_grid.cpp88
-rw-r--r--src/Gudhi_stat/example/vector_representation.cpp80
6 files changed, 485 insertions, 0 deletions
diff --git a/src/Gudhi_stat/example/CMakeLists.txt b/src/Gudhi_stat/example/CMakeLists.txt
new file mode 100644
index 00000000..5ae6cd6a
--- /dev/null
+++ b/src/Gudhi_stat/example/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+add_executable ( persistence_landscape_on_grid persistence_landscape_on_grid.cpp )
+target_link_libraries(persistence_landscape_on_grid ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( persistence_landscape persistence_landscape.cpp )
+target_link_libraries(persistence_landscape ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( persistence_intervals persistence_intervals.cpp )
+target_link_libraries(persistence_intervals ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( vector_representation vector_representation.cpp )
+target_link_libraries(vector_representation ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( persistence_heat_maps persistence_heat_maps.cpp )
+target_link_libraries(persistence_heat_maps ${Boost_SYSTEM_LIBRARY})
+
+
+
+
diff --git a/src/Gudhi_stat/example/persistence_heat_maps.cpp b/src/Gudhi_stat/example/persistence_heat_maps.cpp
new file mode 100644
index 00000000..0e5f7b79
--- /dev/null
+++ b/src/Gudhi_stat/example/persistence_heat_maps.cpp
@@ -0,0 +1,93 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#include <gudhi/reader_utils.h>
+#include <gudhi/persistence_representations/Persistence_heat_maps.h>
+
+#include <iostream>
+#include <vector>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+
+double epsilon = 0.0000005;
+
+
+
+int main( int argc , char** argv )
+{
+ //create two simple vectors with birth--death pairs:
+
+ std::vector< std::pair< double , double > > persistence1;
+ std::vector< std::pair< double , double > > persistence2;
+
+ persistence1.push_back( std::make_pair(1,2) );
+ persistence1.push_back( std::make_pair(6,8) );
+ persistence1.push_back( std::make_pair(0,4) );
+ persistence1.push_back( std::make_pair(3,8) );
+
+ persistence2.push_back( std::make_pair(2,9) );
+ persistence2.push_back( std::make_pair(1,6) );
+ persistence2.push_back( std::make_pair(3,5) );
+ persistence2.push_back( std::make_pair(6,10) );
+
+ //over here we define a function we sill put on a top on every birth--death pair in the persistence interval. It can be anything. Over here we will use standarg Gaussian
+ std::vector< std::vector<double> > filter = create_Gaussian_filter(5,1);
+
+ //creating two heat maps.
+ Persistence_heat_maps<constant_scaling_function> hm1( persistence1 , filter , false , 20 , 0 , 11 );
+ Persistence_heat_maps<constant_scaling_function> hm2( persistence2 , filter , false , 20 , 0 , 11 );
+
+ std::vector<Persistence_heat_maps<constant_scaling_function>*> vector_of_maps;
+ vector_of_maps.push_back( &hm1 );
+ vector_of_maps.push_back( &hm2 );
+
+ //compute median/mean of a vector of heat maps:
+ Persistence_heat_maps<constant_scaling_function> mean;
+ mean.compute_mean( vector_of_maps );
+ Persistence_heat_maps<constant_scaling_function> median;
+ median.compute_median( vector_of_maps );
+
+ //to compute L^1 disance between hm1 and hm2:
+ std::cout << "The L^1 distance is : " << hm1.distance( hm2 , 1 ) << std::endl;
+
+ //to average of hm1 and hm2:
+ std::vector< Persistence_heat_maps<constant_scaling_function>* > to_average;
+ to_average.push_back( &hm1 );
+ to_average.push_back( &hm2 );
+ Persistence_heat_maps<constant_scaling_function> av;
+ av.compute_average( to_average );
+
+ //to compute scalar product of hm1 and hm2:
+ std::cout << "Scalar product is : " << hm1.compute_scalar_product( hm2 ) << std::endl;
+
+ return 0;
+}
+
+
+
+
diff --git a/src/Gudhi_stat/example/persistence_intervals.cpp b/src/Gudhi_stat/example/persistence_intervals.cpp
new file mode 100644
index 00000000..60d5a811
--- /dev/null
+++ b/src/Gudhi_stat/example/persistence_intervals.cpp
@@ -0,0 +1,111 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#include <gudhi/reader_utils.h>
+#include <gudhi/persistence_representations/Persistence_intervals.h>
+
+#include <iostream>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+
+int main( int argc , char** argv )
+{
+ if ( argc != 2 )
+ {
+ std::cout << "To run this program, please provide the name of a file with persistence diagram \n";
+ return 1;
+ }
+
+ Persistence_intervals p( argv[1] );
+ std::pair<double,double> min_max_ = p.min_max();
+ std::cout << "Birth-death range : " << min_max_.first << " " << min_max_.second << std::endl;
+
+
+ std::vector<double> dominant_ten_intervals_length = p.length_of_dominant_intervals(10);
+ std::cout << "Lendth of ten dominant intervals : " <<std::endl;
+ for ( size_t i = 0 ; i != dominant_ten_intervals_length.size() ; ++i )
+ {
+ std::cout << dominant_ten_intervals_length[i] <<std::endl;
+ }
+
+ std::vector< std::pair<double,double> > ten_dominant_intervals = p.dominant_intervals( 10 );
+ std::cout << "Here are the dominant intervals : " <<std::endl;
+ for ( size_t i = 0 ; i != ten_dominant_intervals.size() ; ++i )
+ {
+ std::cout << "( " << ten_dominant_intervals[i].first<< "," << ten_dominant_intervals[i].second <<std::endl;
+ }
+
+ std::vector< size_t > histogram = p.histogram_of_lengths( 10 );
+ std::cout << "Here is the histogram of barcode's length : " <<std::endl;
+ for ( size_t i = 0 ; i != histogram.size() ; ++i )
+ {
+ std::cout << histogram[i] << " ";
+ }
+ std::cout <<std::endl;
+
+
+ std::vector< size_t > cumulative_histogram = p.cumulative_histogram_of_lengths( 10 );
+ std::cout<< "Cumuative histogram : " <<std::endl;
+ for ( size_t i = 0 ; i != cumulative_histogram.size() ; ++i )
+ {
+ std::cout << cumulative_histogram[i] << " ";
+ }
+ std::cout <<std::endl;
+
+ std::vector< double > char_funct_diag = p.characteristic_function_of_diagram( min_max_.first , min_max_.second );
+ std::cout << "Characteristic function of diagram : " <<std::endl;
+ for ( size_t i = 0 ; i != char_funct_diag.size() ; ++i )
+ {
+ std::cout << char_funct_diag[i] << " ";
+ }
+ std::cout <<std::endl;
+
+ std::vector< double > cumul_char_funct_diag = p.cumulative_characteristic_function_of_diagram( min_max_.first , min_max_.second );
+ std::cout << "Cumulative characteristic function of diagram : " <<std::endl;
+ for ( size_t i = 0 ; i != cumul_char_funct_diag.size() ; ++i )
+ {
+ std::cout << cumul_char_funct_diag[i] << " ";
+ }
+ std::cout <<std::endl;
+
+ std::cout << "Persistence Betti numbers \n";
+ std::vector< std::pair< double , size_t > > pbns = p.compute_persistent_betti_numbers();
+ for ( size_t i = 0 ; i != pbns.size() ; ++i )
+ {
+ std::cout << pbns[i].first << " " << pbns[i].second <<std::endl;
+ }
+
+ return 0;
+}
+
+
+
+
+
+
+
diff --git a/src/Gudhi_stat/example/persistence_landscape.cpp b/src/Gudhi_stat/example/persistence_landscape.cpp
new file mode 100644
index 00000000..9385c408
--- /dev/null
+++ b/src/Gudhi_stat/example/persistence_landscape.cpp
@@ -0,0 +1,92 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#include <gudhi/persistence_representations/Persistence_landscape.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+#include <iostream>
+
+
+int main( int argc , char** argv )
+{
+ //create two simple vectors with birth--death pairs:
+
+ std::vector< std::pair< double , double > > persistence1;
+ std::vector< std::pair< double , double > > persistence2;
+
+ persistence1.push_back( std::make_pair(1,2) );
+ persistence1.push_back( std::make_pair(6,8) );
+ persistence1.push_back( std::make_pair(0,4) );
+ persistence1.push_back( std::make_pair(3,8) );
+
+ persistence2.push_back( std::make_pair(2,9) );
+ persistence2.push_back( std::make_pair(1,6) );
+ persistence2.push_back( std::make_pair(3,5) );
+ persistence2.push_back( std::make_pair(6,10) );
+
+ //create two persistence landscapes based on persistence1 and persistence2:
+ Persistence_landscape l1( persistence1 );
+ Persistence_landscape l2( persistence2 );
+
+ //This is how to compute integral of landscapes:
+ std::cout << "Integral of the first landscape : " << l1.compute_integral_of_landscape() << std::endl;
+ std::cout << "Integral of the second landscape : " << l2.compute_integral_of_landscape() << std::endl;
+
+ //And here how to write landscapes to stream:
+ std::cout << "l1 : " << l1 << std::endl;
+ std::cout << "l2 : " << l2 << std::endl;
+
+ //Arythmetic operations on landscapes:
+ Persistence_landscape sum = l1+l2;
+ std::cout << "sum : " << sum << std::endl;
+
+ //here are the maxima of the functions:
+ std::cout << "Maximum of l1 : " << l1.compute_maximum() << std::endl;
+ std::cout << "Maximum of l2 : " << l2.compute_maximum() << std::endl;
+
+ //here are the norms of landscapes:
+ std::cout << "L^1 Norm of l1 : " << l1.compute_norm_of_landscape( 1. ) << std::endl;
+ std::cout << "L^1 Norm of l2 : " << l2.compute_norm_of_landscape( 1. ) << std::endl;
+
+ //here is the average of landscapes:
+ Persistence_landscape average;
+ average.compute_average( {&l1,&l2} );
+ std::cout << "average : " << average << std::endl;
+
+ //here is the distance of landscapes:
+ std::cout << "Distance : " << l1.distance( l2 ) << std::endl;
+
+ //here is the scalar product of landscapes:
+ std::cout << "Scalar product : " << l1.compute_scalar_product( l2 ) << std::endl;
+
+ //here is how to create a file which is suitable for vizualization via gnuplot:
+ average.plot( "average_landscape" );
+
+ return 0;
+}
+
diff --git a/src/Gudhi_stat/example/persistence_landscape_on_grid.cpp b/src/Gudhi_stat/example/persistence_landscape_on_grid.cpp
new file mode 100644
index 00000000..d432d757
--- /dev/null
+++ b/src/Gudhi_stat/example/persistence_landscape_on_grid.cpp
@@ -0,0 +1,88 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#include <gudhi/persistence_representations/Persistence_landscape_on_grid.h>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+#include <iostream>
+
+
+int main( int argc , char** argv )
+{
+ //create two simple vectors with birth--death pairs:
+
+ std::vector< std::pair< double , double > > persistence1;
+ std::vector< std::pair< double , double > > persistence2;
+
+ persistence1.push_back( std::make_pair(1,2) );
+ persistence1.push_back( std::make_pair(6,8) );
+ persistence1.push_back( std::make_pair(0,4) );
+ persistence1.push_back( std::make_pair(3,8) );
+
+ persistence2.push_back( std::make_pair(2,9) );
+ persistence2.push_back( std::make_pair(1,6) );
+ persistence2.push_back( std::make_pair(3,5) );
+ persistence2.push_back( std::make_pair(6,10) );
+
+ //create two persistence landscapes based on persistence1 and persistence2:
+ Persistence_landscape_on_grid l1( persistence1 , 0 , 11 , 20 );
+ Persistence_landscape_on_grid l2( persistence2 , 0 , 11 , 20 );
+
+ //This is how to compute integral of landscapes:
+ std::cout << "Integral of the first landscape : " << l1.compute_integral_of_landscape() << std::endl;
+ std::cout << "Integral of the second landscape : " << l2.compute_integral_of_landscape() << std::endl;
+
+ //And here how to write landscapes to stream:
+ std::cout << "l1 : " << l1 << std::endl;
+ std::cout << "l2 : " << l2 << std::endl;
+
+ //here are the maxima of the functions:
+ std::cout << "Maximum of l1 : " << l1.compute_maximum() << std::endl;
+ std::cout << "Maximum of l2 : " << l2.compute_maximum() << std::endl;
+
+ //here are the norms of landscapes:
+ std::cout << "L^1 Norm of l1 : " << l1.compute_norm_of_landscape( 1. ) << std::endl;
+ std::cout << "L^1 Norm of l2 : " << l2.compute_norm_of_landscape( 1. ) << std::endl;
+
+ //here is the average of landscapes:
+ Persistence_landscape_on_grid average;
+ average.compute_average( {&l1,&l2} );
+ std::cout << "average : " << average << std::endl;
+
+ //here is the distance of landscapes:
+ std::cout << "Distance : " << l1.distance( l2 ) << std::endl;
+
+ //here is the scalar product of landscapes:
+ std::cout << "Scalar product : " << l1.compute_scalar_product( l2 ) << std::endl;
+
+ //here is how to create a file which is suitable for vizualization via gnuplot:
+ average.plot( "average_landscape" );
+
+
+ return 0;
+}
diff --git a/src/Gudhi_stat/example/vector_representation.cpp b/src/Gudhi_stat/example/vector_representation.cpp
new file mode 100644
index 00000000..476deeba
--- /dev/null
+++ b/src/Gudhi_stat/example/vector_representation.cpp
@@ -0,0 +1,80 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#include <gudhi/persistence_representations/Vector_distances_in_diagram.h>
+#include <iostream>
+
+
+#include <gudhi/reader_utils.h>
+#include <vector>
+#include <cmath>
+#include <iomanip>
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+
+
+
+int main( int argc , char** argv )
+{
+ //create two simple vectors with birth--death pairs:
+
+ std::vector< std::pair< double , double > > persistence1;
+ std::vector< std::pair< double , double > > persistence2;
+
+ persistence1.push_back( std::make_pair(1,2) );
+ persistence1.push_back( std::make_pair(6,8) );
+ persistence1.push_back( std::make_pair(0,4) );
+ persistence1.push_back( std::make_pair(3,8) );
+
+ persistence2.push_back( std::make_pair(2,9) );
+ persistence2.push_back( std::make_pair(1,6) );
+ persistence2.push_back( std::make_pair(3,5) );
+ persistence2.push_back( std::make_pair(6,10) );
+
+ //create two persistence vectors based on persistence1 and persistence2:
+ Vector_distances_in_diagram<Euclidean_distance<double> > v1 = Vector_distances_in_diagram<Euclidean_distance<double> >( persistence1 , std::numeric_limits<size_t>::max() );
+ Vector_distances_in_diagram<Euclidean_distance<double> > v2 = Vector_distances_in_diagram<Euclidean_distance<double> >( persistence2 , std::numeric_limits<size_t>::max() );
+
+ //writing to a stream:
+ std::cout << "v1 : " << v1 << std::endl;
+ std::cout << "v2 : " << v2 << std::endl;
+
+ //averages:
+ Vector_distances_in_diagram<Euclidean_distance<double> > average;
+ average.compute_average( {&v1,&v2} );
+ std::cout << "Average : " << average << std::endl;
+
+ //computations of distances:
+ std::cout << "l^1 distance : " << v1.distance( v2 ) << std::endl;
+
+ //computations of scalar product:
+ std::cout << "Scalar product of l1 and l2 : " << v1.compute_scalar_product( v2 ) << std::endl;
+
+ //create a file with a gnuplot script:
+ v1.plot( "plot_of_vector_representation" );
+
+ return 0;
+}