summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Nerve_GIC/example/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
new file mode 100644
index 00000000..871e46a6
--- /dev/null
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required(VERSION 2.6)
+project(Nerve_GIC_examples)
+
+add_executable ( Nerve Nerve.cpp )
+target_link_libraries(Nerve ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( CoordGIC CoordGIC.cpp )
+target_link_libraries(CoordGIC ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( FuncGIC FuncGIC.cpp )
+target_link_libraries(FuncGIC ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( VoronoiGIC VoronoiGIC.cpp )
+target_link_libraries(VoronoiGIC ${Boost_SYSTEM_LIBRARY})
+
+#[[file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)]]
+
+if (TBB_FOUND)
+ target_link_libraries(Nerve ${TBB_LIBRARIES})
+ target_link_libraries(CoordGIC ${TBB_LIBRARIES})
+ target_link_libraries(FuncGIC ${TBB_LIBRARIES})
+ target_link_libraries(VoronoiGIC ${TBB_LIBRARIES})
+endif() \ No newline at end of file