summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Nerve_GIC/example/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
new file mode 100644
index 00000000..b2c501c3
--- /dev/null
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 2.6)
+project(Nerve_GIC_examples)
+
+add_executable ( Nerve Nerve.cpp )
+target_link_libraries(Nerve ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( GIC GIC.cpp )
+target_link_libraries(GIC ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( MapperDeltaCoord MapperDeltaCoord.cpp )
+target_link_libraries(MapperDeltaCoord ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( MapperDeltaFunc MapperDeltaFunc.cpp )
+target_link_libraries(MapperDeltaFunc ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( GICvoronoi GICvoronoi.cpp )
+target_link_libraries(MapperDeltaFunc ${Boost_SYSTEM_LIBRARY})
+
+file(COPY visu.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+if (TBB_FOUND)
+ target_link_libraries(Nerve ${TBB_LIBRARIES})
+ target_link_libraries(GIC ${TBB_LIBRARIES})
+ target_link_libraries(MapperDeltaCoord ${TBB_LIBRARIES})
+ target_link_libraries(MapperDeltaFunc ${TBB_LIBRARIES})
+ target_link_libraries(GICvoronoi ${TBB_LIBRARIES})
+endif() \ No newline at end of file