summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Nerve_GIC/example/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/example/CMakeLists.txt26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
index 871e46a6..461b6db2 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
@@ -2,22 +2,28 @@ cmake_minimum_required(VERSION 2.6)
project(Nerve_GIC_examples)
add_executable ( Nerve Nerve.cpp )
-target_link_libraries(Nerve ${Boost_SYSTEM_LIBRARY})
-
add_executable ( CoordGIC CoordGIC.cpp )
-target_link_libraries(CoordGIC ${Boost_SYSTEM_LIBRARY})
-
add_executable ( FuncGIC FuncGIC.cpp )
-target_link_libraries(FuncGIC ${Boost_SYSTEM_LIBRARY})
-
add_executable ( VoronoiGIC VoronoiGIC.cpp )
-target_link_libraries(VoronoiGIC ${Boost_SYSTEM_LIBRARY})
-
-#[[file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)]]
if (TBB_FOUND)
target_link_libraries(Nerve ${TBB_LIBRARIES})
target_link_libraries(CoordGIC ${TBB_LIBRARIES})
target_link_libraries(FuncGIC ${TBB_LIBRARIES})
target_link_libraries(VoronoiGIC ${TBB_LIBRARIES})
-endif() \ No newline at end of file
+endif()
+
+file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+add_test(NAME Nerve_GIC_example_nerve COMMAND $<TARGET_FILE:Nerve>
+ "${CMAKE_SOURCE_DIR}/data/points/human.off" "2" "10" "0.3")
+
+add_test(NAME Nerve_GIC_example_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+ "${CMAKE_SOURCE_DIR}/data/points/human.off" "100")
+
+add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0")
+
+add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+ "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off"
+ "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1")