summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/test
diff options
context:
space:
mode:
Diffstat (limited to 'src/Nerve_GIC/test')
-rw-r--r--src/Nerve_GIC/test/CMakeLists.txt14
-rw-r--r--src/Nerve_GIC/test/data/cloud6
-rw-r--r--src/Nerve_GIC/test/data/cover3
-rw-r--r--src/Nerve_GIC/test/data/graph3
-rw-r--r--src/Nerve_GIC/test/test_GIC.cpp78
5 files changed, 104 insertions, 0 deletions
diff --git a/src/Nerve_GIC/test/CMakeLists.txt b/src/Nerve_GIC/test/CMakeLists.txt
new file mode 100644
index 00000000..77efe043
--- /dev/null
+++ b/src/Nerve_GIC/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 2.6)
+project(Graph_induced_complex_tests)
+
+include(GUDHI_test_coverage)
+
+add_executable ( Graph_induced_complex_test_unit test_GIC.cpp )
+target_link_libraries(Graph_induced_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(Graph_induced_complex_test_unit ${TBB_LIBRARIES})
+endif()
+
+file(COPY data DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+gudhi_add_coverage_test(Graph_induced_complex_test_unit)
diff --git a/src/Nerve_GIC/test/data/cloud b/src/Nerve_GIC/test/data/cloud
new file mode 100644
index 00000000..4a0c170d
--- /dev/null
+++ b/src/Nerve_GIC/test/data/cloud
@@ -0,0 +1,6 @@
+nOFF
+3
+3 0 0
+0 0 0
+2 1 0
+4 0 0 \ No newline at end of file
diff --git a/src/Nerve_GIC/test/data/cover b/src/Nerve_GIC/test/data/cover
new file mode 100644
index 00000000..5f5fbe75
--- /dev/null
+++ b/src/Nerve_GIC/test/data/cover
@@ -0,0 +1,3 @@
+1
+2
+3 \ No newline at end of file
diff --git a/src/Nerve_GIC/test/data/graph b/src/Nerve_GIC/test/data/graph
new file mode 100644
index 00000000..37142800
--- /dev/null
+++ b/src/Nerve_GIC/test/data/graph
@@ -0,0 +1,3 @@
+0 1
+0 2
+1 2 \ No newline at end of file
diff --git a/src/Nerve_GIC/test/test_GIC.cpp b/src/Nerve_GIC/test/test_GIC.cpp
new file mode 100644
index 00000000..d7af7680
--- /dev/null
+++ b/src/Nerve_GIC/test/test_GIC.cpp
@@ -0,0 +1,78 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Mathieu Carrière
+ *
+ * Copyright (C) 2017 INRIA
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#define BOOST_TEST_DYN_LINK
+#define BOOST_TEST_MODULE "graph_induced_complex"
+
+#include <boost/test/unit_test.hpp>
+#include <cmath> // float comparison
+#include <limits>
+#include <string>
+#include <vector>
+#include <algorithm> // std::max
+#include <gudhi/GIC.h>
+#include <gudhi/distance_functions.h>
+#include <gudhi/reader_utils.h>
+
+BOOST_AUTO_TEST_CASE(check_nerve) {
+
+ using Point = std::vector<float>;
+ Gudhi::cover_complex::Cover_complex<Point> N; N.set_type("Nerve");
+ std::string cloud_file_name("data/cloud"); N.read_point_cloud(cloud_file_name);
+ std::string graph_file_name("data/graph"); N.set_graph_from_file(graph_file_name);
+ std::string cover_file_name("data/cover"); N.set_cover_from_file(cover_file_name);
+ N.find_simplices(); Gudhi::Simplex_tree<> stree; N.create_complex(stree);
+
+ BOOST_CHECK(stree.num_vertices() == 3);
+ BOOST_CHECK((stree.num_simplices()-stree.num_vertices()) == 0);
+ BOOST_CHECK(stree.dimension() == 0);
+}
+
+BOOST_AUTO_TEST_CASE(check_GIC) {
+
+ using Point = std::vector<float>;
+ Gudhi::cover_complex::Cover_complex<Point> GIC; GIC.set_type("GIC");
+ std::string cloud_file_name("data/cloud"); GIC.read_point_cloud(cloud_file_name);
+ std::string graph_file_name("data/graph"); GIC.set_graph_from_file(graph_file_name);
+ std::string cover_file_name("data/cover"); GIC.set_cover_from_file(cover_file_name);
+ GIC.find_simplices(); Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
+
+ BOOST_CHECK(stree.num_vertices() == 3);
+ BOOST_CHECK((stree.num_simplices()-stree.num_vertices()) == 4);
+ BOOST_CHECK(stree.dimension() == 2);
+}
+
+
+BOOST_AUTO_TEST_CASE(check_voronoiGIC) {
+
+ using Point = std::vector<float>;
+ Gudhi::cover_complex::Cover_complex<Point> GIC; GIC.set_type("GIC");
+ std::string cloud_file_name("data/cloud"); GIC.read_point_cloud(cloud_file_name);
+ std::string graph_file_name("data/graph"); GIC.set_graph_from_file(graph_file_name);
+ GIC.set_cover_from_Voronoi(Gudhi::Euclidean_distance(),2);
+ GIC.find_simplices(); Gudhi::Simplex_tree<> stree; GIC.create_complex(stree);
+
+ BOOST_CHECK(stree.num_vertices() == 2);
+ BOOST_CHECK((stree.num_simplices()-stree.num_vertices()) == 1);
+ BOOST_CHECK(stree.dimension() == 1);
+}
+