summaryrefslogtreecommitdiff
path: root/src/Rips_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Rips_complex/example/CMakeLists.txt')
-rw-r--r--src/Rips_complex/example/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Rips_complex/example/CMakeLists.txt b/src/Rips_complex/example/CMakeLists.txt
index fcb1eaee..90c2d9f7 100644
--- a/src/Rips_complex/example/CMakeLists.txt
+++ b/src/Rips_complex/example/CMakeLists.txt
@@ -11,6 +11,9 @@ add_executable ( Rips_complex_example_one_skeleton_from_distance_matrix example_
add_executable ( Rips_complex_example_from_csv_distance_matrix example_rips_complex_from_csv_distance_matrix_file.cpp )
+# Point cloud
+add_executable ( Rips_complex_example_sparse example_sparse_rips.cpp )
+
# Correlation matrix
add_executable ( Rips_complex_example_one_skeleton_rips_from_correlation_matrix example_one_skeleton_rips_from_correlation_matrix.cpp )
@@ -20,6 +23,7 @@ if (TBB_FOUND)
target_link_libraries(Rips_complex_example_one_skeleton_from_distance_matrix ${TBB_LIBRARIES})
target_link_libraries(Rips_complex_example_from_csv_distance_matrix ${TBB_LIBRARIES})
target_link_libraries(Rips_complex_example_one_skeleton_rips_from_correlation_matrix ${TBB_LIBRARIES})
+ target_link_libraries(Rips_complex_example_sparse ${TBB_LIBRARIES})
endif()
add_test(NAME Rips_complex_example_one_skeleton_from_points