summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/example
diff options
context:
space:
mode:
Diffstat (limited to 'src/Simplex_tree/example')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt8
-rw-r--r--src/Simplex_tree/example/graph_expansion_with_blocker.cpp (renamed from src/Simplex_tree/example/block.cpp)1
2 files changed, 5 insertions, 4 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index 4557deb3..c414c019 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -36,8 +36,10 @@ if(GMP_FOUND AND CGAL_FOUND)
install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
endif()
-add_executable ( Simplex_tree_example_block block.cpp )
+add_executable ( Simplex_tree_example_graph_expansion_with_blocker graph_expansion_with_blocker.cpp )
if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_block ${TBB_LIBRARIES})
+ target_link_libraries(Simplex_tree_example_graph_expansion_with_blocker ${TBB_LIBRARIES})
endif()
-add_test(NAME Simplex_tree_example_block COMMAND $<TARGET_FILE:Simplex_tree_example_block>)
+add_test(NAME Simplex_tree_example_graph_expansion_with_blocker COMMAND $<TARGET_FILE:Simplex_tree_example_graph_expansion_with_blocker>)
+
+install(TARGETS Simplex_tree_example_graph_expansion_with_blocker DESTINATION bin)
diff --git a/src/Simplex_tree/example/block.cpp b/src/Simplex_tree/example/graph_expansion_with_blocker.cpp
index 67697b89..d0d3f038 100644
--- a/src/Simplex_tree/example/block.cpp
+++ b/src/Simplex_tree/example/graph_expansion_with_blocker.cpp
@@ -20,7 +20,6 @@
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#include <gudhi/graph_simplicial_complex.h>
#include <gudhi/Simplex_tree.h>
#include <iostream>