summaryrefslogtreecommitdiff
path: root/src/common/example
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/example')
-rw-r--r--src/common/example/CMakeLists.txt6
-rw-r--r--src/common/example/dtoffrw_alphashapedoc_result.off18
2 files changed, 15 insertions, 9 deletions
diff --git a/src/common/example/CMakeLists.txt b/src/common/example/CMakeLists.txt
index 6c2e7669..91e78ea2 100644
--- a/src/common/example/CMakeLists.txt
+++ b/src/common/example/CMakeLists.txt
@@ -13,6 +13,12 @@ if(CGAL_FOUND)
target_link_libraries(dtoffrw ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY})
add_test(dtoffrw ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw ${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off ${CMAKE_CURRENT_BINARY_DIR}/result.off)
+ if (DIFF_PATH)
+ # Do not forget to copy test results files in current binary dir
+ file(COPY "dtoffrw_alphashapedoc_result.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ add_test(dtoffrw_result_off_diff_files ${DIFF_PATH} ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw_alphashapedoc_result.off ${CMAKE_CURRENT_BINARY_DIR}/result.off)
+ endif()
+
else()
message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha shapes feature.")
endif()
diff --git a/src/common/example/dtoffrw_alphashapedoc_result.off b/src/common/example/dtoffrw_alphashapedoc_result.off
index 03b7ca75..d1839a43 100644
--- a/src/common/example/dtoffrw_alphashapedoc_result.off
+++ b/src/common/example/dtoffrw_alphashapedoc_result.off
@@ -1,15 +1,15 @@
nOFF
2 7 6 0
+9 17
+0 14
1 1
-7 0
+2 19
4 6
9 6
-0 14
-2 19
-9 17
-3 0 1 2
-3 3 2 1
-3 4 0 2
-3 4 2 6
-3 6 2 3
+7 0
+3 5 0 4
+3 0 1 4
+3 3 1 0
+3 4 1 2
3 5 4 6
+3 6 4 2