summaryrefslogtreecommitdiff
path: root/src/common/test
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/test')
-rw-r--r--src/common/test/CMakeLists.txt4
-rw-r--r--src/common/test/dtoffrw_alphashapedoc_result.off18
2 files changed, 11 insertions, 11 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index 50655a93..12eecda8 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -22,8 +22,6 @@ if(CGAL_FOUND)
target_link_libraries(dtoffrw_UT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
# Do not forget to copy test files in current binary dir
- file(COPY "dtoffrw_alphashapedoc_result.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- # Do not forget to copy test files in current binary dir
file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
# Unitary tests
@@ -32,6 +30,8 @@ if(CGAL_FOUND)
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/dtoffrw_UT.xml --log_level=test_suite --report_level=no)
if (DIFF_PATH)
+ # Do not forget to copy test result files in current binary dir
+ file(COPY "dtoffrw_alphashapedoc_result.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
add_test(dtoffrw_diff_files_UT ${DIFF_PATH} ${CMAKE_CURRENT_BINARY_DIR}/UT.off ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw_alphashapedoc_result.off)
endif()
diff --git a/src/common/test/dtoffrw_alphashapedoc_result.off b/src/common/test/dtoffrw_alphashapedoc_result.off
index 03b7ca75..d1839a43 100644
--- a/src/common/test/dtoffrw_alphashapedoc_result.off
+++ b/src/common/test/dtoffrw_alphashapedoc_result.off
@@ -1,15 +1,15 @@
nOFF
2 7 6 0
+9 17
+0 14
1 1
-7 0
+2 19
4 6
9 6
-0 14
-2 19
-9 17
-3 0 1 2
-3 3 2 1
-3 4 0 2
-3 4 2 6
-3 6 2 3
+7 0
+3 5 0 4
+3 0 1 4
+3 3 1 0
+3 4 1 2
3 5 4 6
+3 6 4 2