summaryrefslogtreecommitdiff
path: root/src/cython/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/cython/setup.py')
-rw-r--r--src/cython/setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/cython/setup.py b/src/cython/setup.py
index 8439a071..92ed6bbd 100644
--- a/src/cython/setup.py
+++ b/src/cython/setup.py
@@ -5,8 +5,10 @@ gudhi = Extension(
"gudhi",
sources = ['gudhi.pyx',],
language = 'c++',
- extra_compile_args=['-std=c++11'],
- include_dirs = ['../include','./src/cpp'],
+ extra_compile_args=['-frounding-math','-std=c++11','-DCGAL_EIGEN3_ENABLED','-DCGAL_USE_GMP','-DCGAL_USE_GMPXX','-DCGAL_USE_MPFR'],
+ libraries=['mpfr','gmpxx','gmp','CGAL'],
+ library_dirs=['/usr/local/lib/'],
+ include_dirs = ['../include','./src/cpp','/usr/local/include/eigen3'],
)
setup(