summaryrefslogtreecommitdiff
path: root/src/python
diff options
context:
space:
mode:
Diffstat (limited to 'src/python')
-rw-r--r--src/python/CMakeLists.txt3
-rw-r--r--src/python/gudhi/__init__.py.in3
-rw-r--r--src/python/gudhi/_distributor_init.py18
-rw-r--r--src/python/setup.py.in1
4 files changed, 1 insertions, 24 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index b35c8de7..966f5ef0 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -237,9 +237,6 @@ if(PYTHONINTERP_FOUND)
# Some files for pip package
file(COPY "introduction.rst" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/")
- file(COPY "gudhi/_distributor_init.py" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/gudhi")
- file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/gudhi/.libs")
- message(" o o o ${CMAKE_CURRENT_BINARY_DIR}/gudhi/.libs")
add_custom_command(
OUTPUT gudhi.so
diff --git a/src/python/gudhi/__init__.py.in b/src/python/gudhi/__init__.py.in
index e4198dcf..79e12fbc 100644
--- a/src/python/gudhi/__init__.py.in
+++ b/src/python/gudhi/__init__.py.in
@@ -10,9 +10,6 @@
from importlib import import_module
from sys import exc_info
-# Allow distributors to run custom init code
-from . import _distributor_init
-
__author__ = "GUDHI Editorial Board"
__copyright__ = "Copyright (C) 2016 Inria"
__license__ = "https://gudhi.inria.fr/licensing/"
diff --git a/src/python/gudhi/_distributor_init.py b/src/python/gudhi/_distributor_init.py
deleted file mode 100644
index 6f3dc8a2..00000000
--- a/src/python/gudhi/_distributor_init.py
+++ /dev/null
@@ -1,18 +0,0 @@
-'''
-Helper to preload windows dlls to prevent dll not found errors.
-Once a DLL is preloaded, its namespace is made available to any subsequent DLL.
-'''
-import os
-if os.name == 'nt':
- # convention for storing / loading the DLL from gudhi/.libs/, if present
- try:
- basedir = os.path.dirname(__file__)
- except:
- pass
- else:
- libs_dir = os.path.abspath(os.path.join(basedir, '.libs'))
- if os.path.isdir(libs_dir):
- from ctypes import WinDLL
- import glob
- for filename in glob.glob(os.path.join(libs_dir, '*dll')):
- WinDLL(os.path.abspath(filename))
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 875f1577..07ad818f 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -86,4 +86,5 @@ setup(
ext_modules = ext_modules,
install_requires = ['numpy >= 1.9',],
setup_requires = ['cython','numpy >= 1.9','pybind11',],
+ package_data={"": ["*.dll"], },
)