summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/python/CMakeLists.txt5
-rw-r--r--src/python/test/test_perslay.py2
2 files changed, 6 insertions, 1 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 344e988f..f6750a30 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -572,6 +572,11 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_diff)
endif()
+ # Perslay
+ if(TENSORFLOW_FOUND AND SKLEARN_FOUND)
+ add_gudhi_py_test(test_perslay)
+ endif()
+
# Betti curves
if(SKLEARN_FOUND AND SCIPY_FOUND)
add_gudhi_py_test(test_betti_curve_representations)
diff --git a/src/python/test/test_perslay.py b/src/python/test/test_perslay.py
index bf0d54af..06497712 100644
--- a/src/python/test/test_perslay.py
+++ b/src/python/test/test_perslay.py
@@ -1,7 +1,7 @@
import numpy as np
import tensorflow as tf
from sklearn.preprocessing import MinMaxScaler
-from gudhi.tensorflow import *
+from gudhi.tensorflow.perslay import *
import gudhi.representations as gdr
def test_gaussian_perslay():