summaryrefslogtreecommitdiff
path: root/trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt')
-rw-r--r--trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt b/trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt
new file mode 100644
index 00000000..02b026f2
--- /dev/null
+++ b/trunk/src/Bitmap_cubical_complex/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+project(Bitmap_cubical_complex_tests)
+
+include(GUDHI_test_coverage)
+
+add_executable ( Bitmap_cubical_complex_test_unit Bitmap_test.cpp )
+target_link_libraries(Bitmap_cubical_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(Bitmap_cubical_complex_test_unit ${TBB_LIBRARIES})
+endif()
+
+gudhi_add_coverage_test(Bitmap_cubical_complex_test_unit)