summaryrefslogtreecommitdiff
path: root/trunk/src/Contraction/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/Contraction/example/CMakeLists.txt')
-rw-r--r--trunk/src/Contraction/example/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/trunk/src/Contraction/example/CMakeLists.txt b/trunk/src/Contraction/example/CMakeLists.txt
new file mode 100644
index 00000000..83594c0e
--- /dev/null
+++ b/trunk/src/Contraction/example/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+project(Contraction_examples)
+
+
+add_executable(RipsContraction Rips_contraction.cpp)
+add_executable(GarlandHeckbert Garland_heckbert.cpp)
+
+add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0.2")
+# TODO(DS) : These tests are too long under Windows
+#add_test(NAME Contraction_example_sphere_0.2 COMMAND $<TARGET_FILE:RipsContraction>
+# "${CMAKE_SOURCE_DIR}/data/points/sphere3D_2646.off" "0.2")
+#add_test(NAME Contraction_example_SO3_0.3 COMMAND $<TARGET_FILE:RipsContraction>
+# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off" "0.3")
+
+install(TARGETS RipsContraction DESTINATION bin)
+install(TARGETS GarlandHeckbert DESTINATION bin)