summaryrefslogtreecommitdiff
path: root/trunk/src/Skeleton_blocker/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/Skeleton_blocker/example/CMakeLists.txt')
-rw-r--r--trunk/src/Skeleton_blocker/example/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/trunk/src/Skeleton_blocker/example/CMakeLists.txt b/trunk/src/Skeleton_blocker/example/CMakeLists.txt
new file mode 100644
index 00000000..de70f089
--- /dev/null
+++ b/trunk/src/Skeleton_blocker/example/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 2.6)
+project(Skeleton_blocker_examples)
+
+add_executable(Skeleton_blocker_example_from_simplices Skeleton_blocker_from_simplices.cpp)
+add_executable(Skeleton_blocker_example_iteration Skeleton_blocker_iteration.cpp)
+add_executable(Skeleton_blocker_example_link Skeleton_blocker_link.cpp)
+
+add_test(NAME Skeleton_blocker_example_from_simplices COMMAND $<TARGET_FILE:Skeleton_blocker_example_from_simplices>)
+add_test(NAME Skeleton_blocker_example_iteration COMMAND $<TARGET_FILE:Skeleton_blocker_example_iteration>)
+add_test(NAME Skeleton_blocker_example_link COMMAND $<TARGET_FILE:Skeleton_blocker_example_link>)
+
+install(TARGETS Skeleton_blocker_example_from_simplices DESTINATION bin)
+install(TARGETS Skeleton_blocker_example_iteration DESTINATION bin)
+install(TARGETS Skeleton_blocker_example_link DESTINATION bin)