summaryrefslogtreecommitdiff
path: root/trunk/src/Skeleton_blocker/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/Skeleton_blocker/test/CMakeLists.txt')
-rw-r--r--trunk/src/Skeleton_blocker/test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/trunk/src/Skeleton_blocker/test/CMakeLists.txt b/trunk/src/Skeleton_blocker/test/CMakeLists.txt
new file mode 100644
index 00000000..4a363294
--- /dev/null
+++ b/trunk/src/Skeleton_blocker/test/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 2.6)
+project(Skeleton_blocker_tests)
+
+include(GUDHI_test_coverage)
+
+add_executable ( Skeleton_blocker_test_unit test_skeleton_blocker_complex.cpp )
+target_link_libraries(Skeleton_blocker_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+add_executable ( Skeleton_blocker_test_geometric_complex test_skeleton_blocker_geometric_complex.cpp )
+target_link_libraries(Skeleton_blocker_test_geometric_complex ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+add_executable ( Skeleton_blocker_test_simplifiable test_skeleton_blocker_simplifiable.cpp )
+target_link_libraries(Skeleton_blocker_test_simplifiable ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
+# Do not forget to copy test files in current binary dir
+file(COPY "test2.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+gudhi_add_coverage_test(Skeleton_blocker_test_unit)
+gudhi_add_coverage_test(Skeleton_blocker_test_geometric_complex)
+gudhi_add_coverage_test(Skeleton_blocker_test_simplifiable)