summaryrefslogtreecommitdiff
path: root/utilities/Bitmap_cubical_complex
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Bitmap_cubical_complex')
-rw-r--r--utilities/Bitmap_cubical_complex/CMakeLists.txt28
-rw-r--r--utilities/Bitmap_cubical_complex/cubical_complex_persistence.cpp80
-rw-r--r--utilities/Bitmap_cubical_complex/cubicalcomplex.md37
-rw-r--r--utilities/Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp82
4 files changed, 0 insertions, 227 deletions
diff --git a/utilities/Bitmap_cubical_complex/CMakeLists.txt b/utilities/Bitmap_cubical_complex/CMakeLists.txt
deleted file mode 100644
index 416db67f..00000000
--- a/utilities/Bitmap_cubical_complex/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-project(Bitmap_cubical_complex_utilities)
-
-add_executable ( cubical_complex_persistence cubical_complex_persistence.cpp )
-if (TBB_FOUND)
- target_link_libraries(cubical_complex_persistence ${TBB_LIBRARIES})
-endif()
-
-add_test(NAME Bitmap_cubical_complex_utility_persistence_one_sphere COMMAND $<TARGET_FILE:cubical_complex_persistence>
- "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")
-
-add_test(NAME Bitmap_cubical_complex_utility_persistence_two_sphere COMMAND $<TARGET_FILE:cubical_complex_persistence>
- "${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt")
-
-add_executable ( periodic_cubical_complex_persistence periodic_cubical_complex_persistence.cpp )
-if (TBB_FOUND)
- target_link_libraries(periodic_cubical_complex_persistence ${TBB_LIBRARIES})
-endif()
-
-add_test(NAME Bitmap_cubical_complex_utility_periodic_boundary_conditions_2d_torus
- COMMAND $<TARGET_FILE:periodic_cubical_complex_persistence>
- "${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt")
-
-add_test(NAME Bitmap_cubical_complex_utility_periodic_boundary_conditions_3d_torus
- COMMAND $<TARGET_FILE:periodic_cubical_complex_persistence>
- "${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt")
-
-install(TARGETS cubical_complex_persistence DESTINATION bin)
-install(TARGETS periodic_cubical_complex_persistence DESTINATION bin)
diff --git a/utilities/Bitmap_cubical_complex/cubical_complex_persistence.cpp b/utilities/Bitmap_cubical_complex/cubical_complex_persistence.cpp
deleted file mode 100644
index 170aa684..00000000
--- a/utilities/Bitmap_cubical_complex/cubical_complex_persistence.cpp
+++ /dev/null
@@ -1,80 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2015 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/reader_utils.h>
-#include <gudhi/Bitmap_cubical_complex.h>
-#include <gudhi/Persistent_cohomology.h>
-
-// standard stuff
-#include <iostream>
-#include <string>
-#include <vector>
-#include <cstddef>
-
-int main(int argc, char** argv) {
- std::cout
- << "This program computes persistent homology, by using bitmap_cubical_complex class, of cubical "
- << "complexes provided in text files in Perseus style (the only numbered in the first line is a dimension D of a"
- << "bitmap. In the lines I between 2 and D+1 there are numbers of top dimensional cells in the direction I. Let "
- << "N denote product of the numbers in the lines between 2 and D. In the lines D+2 to D+2+N there are "
- << "filtrations of top dimensional cells. We assume that the cells are in the lexicographical order. See "
- << "CubicalOneSphere.txt or CubicalTwoSphere.txt for example.\n"
- << std::endl;
-
- if (argc != 2) {
- std::cerr << "Wrong number of parameters. Please provide the name of a file with a Perseus style bitmap at "
- << "the input. The program will now terminate.\n";
- return 1;
- }
-
- typedef Gudhi::cubical_complex::Bitmap_cubical_complex_base<double> Bitmap_cubical_complex_base;
- typedef Gudhi::cubical_complex::Bitmap_cubical_complex<Bitmap_cubical_complex_base> Bitmap_cubical_complex;
- typedef Gudhi::persistent_cohomology::Field_Zp Field_Zp;
- typedef Gudhi::persistent_cohomology::Persistent_cohomology<Bitmap_cubical_complex, Field_Zp> Persistent_cohomology;
-
- Bitmap_cubical_complex b(argv[1]);
-
- // Compute the persistence diagram of the complex
- Persistent_cohomology pcoh(b);
- int p = 11;
- double min_persistence = 0;
-
- pcoh.init_coefficients(p); // initializes the coefficient field for homology
- pcoh.compute_persistent_cohomology(min_persistence);
-
- std::string output_file_name(argv[1]);
- output_file_name += "_persistence";
-
- std::size_t last_in_path = output_file_name.find_last_of("/\\");
-
- if (last_in_path != std::string::npos) {
- output_file_name = output_file_name.substr(last_in_path + 1);
- }
-
- std::ofstream out(output_file_name.c_str());
- pcoh.output_diagram(out);
- out.close();
-
- std::cout << "Result in file: " << output_file_name << "\n";
-
- return 0;
-}
diff --git a/utilities/Bitmap_cubical_complex/cubicalcomplex.md b/utilities/Bitmap_cubical_complex/cubicalcomplex.md
deleted file mode 100644
index 5b0404c3..00000000
--- a/utilities/Bitmap_cubical_complex/cubicalcomplex.md
+++ /dev/null
@@ -1,37 +0,0 @@
----
-layout: page
-title: "Cubical complex"
-meta_title: "Cubical complex"
-teaser: ""
-permalink: /cubicalcomplex/
----
-{::comment}
-Leave the lines above as it is required by the web site generator 'Jekyll'
-{:/comment}
-
-
-## cubical_complex_persistence ##
-This program computes persistent homology, by using the Bitmap_cubical_complex class, of cubical complexes provided in text files in Perseus style.
-See [here](/doc/latest/fileformats.html#FileFormatsPerseus) for a description of the file format.
-
-**Example**
-
-```
- cubical_complex_persistence data/bitmap/CubicalTwoSphere.txt
-```
-
-* Creates a Cubical Complex from the Perseus style file `CubicalTwoSphere.txt`,
-computes Persistence cohomology from it and writes the results in a persistence file `CubicalTwoSphere.txt_persistence`.
-
-## periodic_cubical_complex_persistence ##
-
-Same as above, but with periodic boundary conditions.
-
-**Example**
-
-```
- periodic_cubical_complex_persistence data/bitmap/3d_torus.txt
-```
-
-* Creates a Periodical Cubical Complex from the Perseus style file `3d_torus.txt`,
-computes Persistence cohomology from it and writes the results in a persistence file `3d_torus.txt_persistence`.
diff --git a/utilities/Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp b/utilities/Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp
deleted file mode 100644
index e9ba5495..00000000
--- a/utilities/Bitmap_cubical_complex/periodic_cubical_complex_persistence.cpp
+++ /dev/null
@@ -1,82 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2015 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/reader_utils.h>
-#include <gudhi/Bitmap_cubical_complex.h>
-#include <gudhi/Bitmap_cubical_complex_periodic_boundary_conditions_base.h>
-#include <gudhi/Persistent_cohomology.h>
-
-// standard stuff
-#include <iostream>
-#include <sstream>
-#include <vector>
-#include <string>
-
-int main(int argc, char** argv) {
- std::cout
- << "This program computes persistent homology, by using "
- << "Bitmap_cubical_complex_periodic_boundary_conditions class, of cubical complexes provided in text files in "
- << "Perseus style (the only numbered in the first line is a dimension D of a bitmap. In the lines I between 2 "
- << "and D+1 there are numbers of top dimensional cells in the direction I. Let N denote product of the numbers "
- << "in the lines between 2 and D. In the lines D+2 to D+2+N there are filtrations of top dimensional cells. We "
- << "assume that the cells are in the lexicographical order. See CubicalOneSphere.txt or CubicalTwoSphere.txt for"
- << " example.\n"
- << std::endl;
-
- if (argc != 2) {
- std::cerr << "Wrong number of parameters. Please provide the name of a file with a Perseus style bitmap at "
- << "the input. The program will now terminate.\n";
- return 1;
- }
-
- typedef Gudhi::cubical_complex::Bitmap_cubical_complex_periodic_boundary_conditions_base<double> Bitmap_base;
- typedef Gudhi::cubical_complex::Bitmap_cubical_complex<Bitmap_base> Bitmap_cubical_complex;
-
- Bitmap_cubical_complex b(argv[1]);
-
- typedef Gudhi::persistent_cohomology::Field_Zp Field_Zp;
- typedef Gudhi::persistent_cohomology::Persistent_cohomology<Bitmap_cubical_complex, Field_Zp> Persistent_cohomology;
- // Compute the persistence diagram of the complex
- Persistent_cohomology pcoh(b, true);
-
- int p = 11;
- double min_persistence = 0;
- pcoh.init_coefficients(p); // initializes the coefficient field for homology
- pcoh.compute_persistent_cohomology(min_persistence);
-
- std::string output_file_name(argv[1]);
- output_file_name += "_persistence";
-
- std::size_t last_in_path = output_file_name.find_last_of("/\\");
-
- if (last_in_path != std::string::npos) {
- output_file_name = output_file_name.substr(last_in_path + 1);
- }
-
- std::ofstream out(output_file_name.c_str());
- pcoh.output_diagram(out);
- out.close();
-
- std::cout << "Result in file: " << output_file_name << "\n";
-
- return 0;
-}