summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2021-08-14 19:08:03 +0200
committerGard Spreemann <gspr@nonempty.org>2021-08-14 19:08:03 +0200
commitebe0285eabd613b755c5506e02924894679661b7 (patch)
treec78ce547606e5bbe85849071a59f312fd9b82f42
parentc84570609db94aae192a2bdec4d99a334156c4be (diff)
Depend on PHAT, and add patch for using system PHAT
-rw-r--r--debian/changelog3
-rw-r--r--debian/control5
-rw-r--r--debian/patches/0002-Use-system-PHAT.patch55
-rw-r--r--debian/patches/series1
4 files changed, 62 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 9473d80..7439eac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ hera (0~git20210508+dfsg-1) unstable; urgency=medium
- Refresh patch.
* Correct upstream metadata.
* Drop unneccessary version bounds.
+ * Actually depend on PHAT.
+ - Add patch to use the system PHAT version instead of DFSG-deleted
+ bundled copy.
-- Gard Spreemann <gspr@nonempty.org> Sat, 14 Aug 2021 18:42:03 +0200
diff --git a/debian/control b/debian/control
index 878966f..9b6e71c 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,8 @@ Standards-Version: 4.5.1
Build-Depends: catch2,
cmake,
debhelper-compat (= 13),
- libboost-dev
+ libboost-dev,
+ libphat-dev
Rules-Requires-Root: no
Homepage: https://github.com/grey-narn/hera/
Vcs-Browser: https://salsa.debian.org/gspr/hera
@@ -16,7 +17,7 @@ Package: libhera-dev
Section: libdevel
Architecture: all
Multi-Arch: foreign
-Depends: libboost-dev, ${misc:Depends}
+Depends: libboost-dev, libphat-dev, ${misc:Depends}
Description: Library for efficient bottleneck and Wasserstein distances
A header-only C++ library for efficient computation of bottleneck and
Wasserstein distances between persistence diagrams.
diff --git a/debian/patches/0002-Use-system-PHAT.patch b/debian/patches/0002-Use-system-PHAT.patch
new file mode 100644
index 0000000..b99adc6
--- /dev/null
+++ b/debian/patches/0002-Use-system-PHAT.patch
@@ -0,0 +1,55 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Sat, 14 Aug 2021 19:05:48 +0200
+Subject: Use system PHAT
+
+---
+ matching/include/bifiltration.h | 4 ++--
+ matching/include/common_util.h | 2 +-
+ matching/include/persistence_module.h | 6 +++---
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/matching/include/bifiltration.h b/matching/include/bifiltration.h
+index 5b188d4..25b3bff 100644
+--- a/matching/include/bifiltration.h
++++ b/matching/include/bifiltration.h
+@@ -12,8 +12,8 @@
+ #include "box.h"
+ #include "simplex.h"
+ #include "dual_point.h"
+-#include "phat/boundary_matrix.h"
+-#include "phat/compute_persistence_pairs.h"
++#include <phat/boundary_matrix.h>
++#include <phat/compute_persistence_pairs.h>
+
+ #include "common_util.h"
+
+diff --git a/matching/include/common_util.h b/matching/include/common_util.h
+index 20a151a..61476a5 100644
+--- a/matching/include/common_util.h
++++ b/matching/include/common_util.h
+@@ -12,7 +12,7 @@
+ #include <functional>
+
+ #include "common_defs.h"
+-#include "phat/helpers/misc.h"
++#include <phat/helpers/misc.h>
+
+ namespace md {
+
+diff --git a/matching/include/persistence_module.h b/matching/include/persistence_module.h
+index 4df2148..80ff3c1 100644
+--- a/matching/include/persistence_module.h
++++ b/matching/include/persistence_module.h
+@@ -9,9 +9,9 @@
+ #include <algorithm>
+ #include <unordered_set>
+
+-#include "phat/boundary_matrix.h"
+-#include "phat/compute_persistence_pairs.h"
+-#include "phat/algorithms/standard_reduction.h"
++#include <phat/boundary_matrix.h>
++#include <phat/compute_persistence_pairs.h>
++#include <phat/algorithms/standard_reduction.h>
+
+ #include "common_util.h"
+ #include "dual_point.h"
diff --git a/debian/patches/series b/debian/patches/series
index 06ec138..78f2fb4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-Use-system-catch2.patch
+0002-Use-system-PHAT.patch