summaryrefslogtreecommitdiff
path: root/wasserstein/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2022-04-29 13:56:44 +0200
committerGard Spreemann <gspr@nonempty.org>2022-04-29 13:56:44 +0200
commit25ecf3d4f7da739ec6a96ae3746498b1ae6e21f3 (patch)
tree4cd624d4380517400b60788ee5dd38b17f50244b /wasserstein/tests/CMakeLists.txt
parente43fec46f5279e5d36d8fd5febc0cd5c357773ee (diff)
parentfb4866e1d827389db17d74e5986d848617c8ef72 (diff)
Merge branch 'dfsg/latest' into debian/sid
Diffstat (limited to 'wasserstein/tests/CMakeLists.txt')
-rw-r--r--wasserstein/tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/wasserstein/tests/CMakeLists.txt b/wasserstein/tests/CMakeLists.txt
new file mode 100644
index 0000000..b379da2
--- /dev/null
+++ b/wasserstein/tests/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_executable(wasserstein_test tests_main.cpp test_hera_wasserstein.cpp test_hera_wasserstein_pure_geom.cpp)
+target_link_libraries(wasserstein_test PRIVATE ${libraries})
+
+target_include_directories(tests PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/../include
+ ${CMAKE_CURRENT_SOURCE_DIR}../extern/Catch2/src)
+
+target_link_libraries(tests PRIVATE Catch2::Catch2WithMain)
+
+add_test(NAME all COMMAND wasserstein_test)