summaryrefslogtreecommitdiff
path: root/wasserstein/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorArnur Nigmetov <anigmetov@lbl.gov>2022-04-09 17:33:15 -0700
committerArnur Nigmetov <anigmetov@lbl.gov>2022-04-09 17:33:15 -0700
commit8fbae1d789b3c9d7e9b079284c85489d8dcd7e65 (patch)
treec884ea100a702c7a6cb1cef083168ed59d7e0f31 /wasserstein/tests/CMakeLists.txt
parente62d16d7b1c42163de7b21ab74a780c3c1cf8e45 (diff)
Major cleanupupstream/latest
Diffstat (limited to 'wasserstein/tests/CMakeLists.txt')
-rw-r--r--wasserstein/tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/wasserstein/tests/CMakeLists.txt b/wasserstein/tests/CMakeLists.txt
new file mode 100644
index 0000000..b379da2
--- /dev/null
+++ b/wasserstein/tests/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_executable(wasserstein_test tests_main.cpp test_hera_wasserstein.cpp test_hera_wasserstein_pure_geom.cpp)
+target_link_libraries(wasserstein_test PRIVATE ${libraries})
+
+target_include_directories(tests PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/../include
+ ${CMAKE_CURRENT_SOURCE_DIR}../extern/Catch2/src)
+
+target_link_libraries(tests PRIVATE Catch2::Catch2WithMain)
+
+add_test(NAME all COMMAND wasserstein_test)