summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat2
-rw-r--r--debian/control29
-rw-r--r--debian/libhera-dev.install2
-rw-r--r--debian/patches/0001-Use-system-catch2.patch114
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/source/format1
8 files changed, 161 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..b950951
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+hera (0~git20200602-1) UNRELEASED; urgency=medium
+
+ * Initial commit, upstream commit
+ b73ed1face2c609958556e6f2b7704bbd8aaa263. (Closes: #961784)
+
+ -- Gard Spreemann <gspr@nonempty.org> Tue, 02 Jun 2020 20:40:30 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f5d273e
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1,2 @@
+12
+
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a9c96e0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: hera
+Maintainer: Gard Spreemann <gspr@nonempty.org>
+Section: math
+Priority: optional
+Standards-Version: 4.5.0.2
+Build-Depends: catch2,
+ cmake (>= 3.5.1),
+ debhelper (>= 12),
+ libboost-dev
+Rules-Requires-Root: no
+Homepage: https://github.com/grey-narn/hera/
+Vcs-Browser: https://git.nonempty.org/debian-hera
+Vcs-Git: https://git.nonempty.org/debian-hera -b debian/sid
+
+Package: libhera-dev
+Section: libdevel
+Architecture: all
+Multi-Arch: foreign
+Depends: libboost-dev,
+ ${misc:Depends}
+Description: FIXME
+ FIXME
+
+Package: hera-utils
+Section: math
+Architecture: any
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: FIXME
+ FIXME
diff --git a/debian/libhera-dev.install b/debian/libhera-dev.install
new file mode 100644
index 0000000..a0ad680
--- /dev/null
+++ b/debian/libhera-dev.install
@@ -0,0 +1,2 @@
+bottleneck/include/* /usr/include/hera/bottleneck/
+wasserstein/include/* /usr/include/hera/wasserstein/
diff --git a/debian/patches/0001-Use-system-catch2.patch b/debian/patches/0001-Use-system-catch2.patch
new file mode 100644
index 0000000..264bf46
--- /dev/null
+++ b/debian/patches/0001-Use-system-catch2.patch
@@ -0,0 +1,114 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 3 Jun 2020 09:32:19 +0200
+Subject: Use system catch2.
+
+---
+ bottleneck/tests/test_hera_bottleneck.cpp | 2 +-
+ bottleneck/tests/tests_main.cpp | 2 +-
+ matching/tests/test_bifiltration.cpp | 2 +-
+ matching/tests/test_common.cpp | 2 +-
+ matching/tests/test_matching_distance.cpp | 2 +-
+ matching/tests/test_module.cpp | 2 +-
+ matching/tests/tests_main.cpp | 2 +-
+ wasserstein/tests/test_hera_wasserstein.cpp | 2 +-
+ wasserstein/tests/test_hera_wasserstein_pure_geom.cpp | 2 +-
+ wasserstein/tests/tests_main.cpp | 2 +-
+ 10 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/bottleneck/tests/test_hera_bottleneck.cpp b/bottleneck/tests/test_hera_bottleneck.cpp
+index f22e415..9fcc8d0 100644
+--- a/bottleneck/tests/test_hera_bottleneck.cpp
++++ b/bottleneck/tests/test_hera_bottleneck.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/bottleneck/tests/tests_main.cpp b/bottleneck/tests/tests_main.cpp
+index d24407e..1f558c8 100644
+--- a/bottleneck/tests/tests_main.cpp
++++ b/bottleneck/tests/tests_main.cpp
+@@ -1,3 +1,3 @@
+ #define LOG_AUCTION
+ #define CATCH_CONFIG_MAIN
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+diff --git a/matching/tests/test_bifiltration.cpp b/matching/tests/test_bifiltration.cpp
+index 742dab8..f63e231 100644
+--- a/matching/tests/test_bifiltration.cpp
++++ b/matching/tests/test_bifiltration.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/matching/tests/test_common.cpp b/matching/tests/test_common.cpp
+index 9079a56..d390585 100644
+--- a/matching/tests/test_common.cpp
++++ b/matching/tests/test_common.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/matching/tests/test_matching_distance.cpp b/matching/tests/test_matching_distance.cpp
+index 115c8d9..08c59c0 100644
+--- a/matching/tests/test_matching_distance.cpp
++++ b/matching/tests/test_matching_distance.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/matching/tests/test_module.cpp b/matching/tests/test_module.cpp
+index bae1f78..3dbe5b1 100644
+--- a/matching/tests/test_module.cpp
++++ b/matching/tests/test_module.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/matching/tests/tests_main.cpp b/matching/tests/tests_main.cpp
+index 1c77b13..4ed06df 100644
+--- a/matching/tests/tests_main.cpp
++++ b/matching/tests/tests_main.cpp
+@@ -1,2 +1,2 @@
+ #define CATCH_CONFIG_MAIN
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+diff --git a/wasserstein/tests/test_hera_wasserstein.cpp b/wasserstein/tests/test_hera_wasserstein.cpp
+index 0a80d2f..dc935e8 100644
+--- a/wasserstein/tests/test_hera_wasserstein.cpp
++++ b/wasserstein/tests/test_hera_wasserstein.cpp
+@@ -1,5 +1,5 @@
+ #define LOG_AUCTION
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/wasserstein/tests/test_hera_wasserstein_pure_geom.cpp b/wasserstein/tests/test_hera_wasserstein_pure_geom.cpp
+index 9603ceb..3110c4c 100644
+--- a/wasserstein/tests/test_hera_wasserstein_pure_geom.cpp
++++ b/wasserstein/tests/test_hera_wasserstein_pure_geom.cpp
+@@ -1,4 +1,4 @@
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
+
+ #include <sstream>
+ #include <iostream>
+diff --git a/wasserstein/tests/tests_main.cpp b/wasserstein/tests/tests_main.cpp
+index d24407e..1f558c8 100644
+--- a/wasserstein/tests/tests_main.cpp
++++ b/wasserstein/tests/tests_main.cpp
+@@ -1,3 +1,3 @@
+ #define LOG_AUCTION
+ #define CATCH_CONFIG_MAIN
+-#include "catch/catch.hpp"
++#include <catch2/catch.hpp>
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..06ec138
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Use-system-catch2.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d8309f6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,6 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)