summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryn Keller <xoltar314@gmail.com>2020-03-09 21:57:57 +0000
committermkerber <kerber@tugraz.at>2020-03-09 21:57:57 +0000
commit46116abeb6cab4893ac774e85efed5e3b87d5485 (patch)
tree457f557933a14a6e606efb22a07cf7e58ff8aa54
parentdaea707b05305fa4ac3ee6e689f12d0ff673a8dd (diff)
parent5485d57c5632c54c5c377a17672b88357c6455db (diff)
Merged in xoltar/phat/example-use-default-repr (pull request #2)
Use default representation for example rather than vector_vector
-rw-r--r--python/README.rst6
-rw-r--r--python/src/simple_example.py6
-rw-r--r--setup.py3
3 files changed, 10 insertions, 5 deletions
diff --git a/python/README.rst b/python/README.rst
index 0c6c391..52bc150 100644
--- a/python/README.rst
+++ b/python/README.rst
@@ -99,8 +99,10 @@ Now the code::
import phat
- # define a boundary matrix with the chosen internal representation
- boundary_matrix = phat.boundary_matrix(representation = phat.representations.vector_vector)
+ boundary_matrix = phat.boundary_matrix()
+
+ # or define a boundary matrix with the chosen internal representation
+ # boundary_matrix = phat.boundary_matrix(representation = phat.representations.bit_tree_pivot_column)
# set the respective columns -- (dimension, boundary) pairs
boundary_matrix.columns = [ (0, []),
diff --git a/python/src/simple_example.py b/python/src/simple_example.py
index 955e213..7aa6214 100644
--- a/python/src/simple_example.py
+++ b/python/src/simple_example.py
@@ -21,8 +21,10 @@ if __name__ == "__main__":
import phat
- # define a boundary matrix with the chosen internal representation
- boundary_matrix = phat.boundary_matrix(representation = phat.representations.vector_vector)
+ boundary_matrix = phat.boundary_matrix()
+
+ # or define a boundary matrix with the chosen internal representation
+ # boundary_matrix = phat.boundary_matrix(representation = phat.representations.bit_tree_pivot_column)
# set the respective columns -- (dimension, boundary) pairs
boundary_matrix.columns = [ (0, []),
diff --git a/setup.py b/setup.py
index 1ce0e51..46dadbb 100644
--- a/setup.py
+++ b/setup.py
@@ -51,7 +51,7 @@ if sys.version_info < (3,4,0):
setup(
name='phat',
- version='1.5.0',
+ version='1.5.0.post2',
author='Bryn Keller',
author_email='bryn.keller@intel.com',
url='https://bitbucket.org/phat-code/phat',
@@ -60,6 +60,7 @@ setup(
keywords='algebraic-topology PHAT distributed topology persistent-homology',
long_description=long_description,
ext_modules=ext_modules,
+ requires=requires,
install_requires=requires,
cmdclass={'build_ext': BuildExt},
package_dir={'':'python'},